New Forum system requires email address which you used to apply for your account to replace your original username. Password stays the same.Please see this post for more details
http://forum.yealink.com/forum/showthread.php?tid=40344

Yealink Test Club has been officially launched. Please visit post below to get detail information. Come and join us!
http://forum.yealink.com/forum/announcements.php?aid=18

We just had the YMCS online and we are also working on the features plan on the future versions, in this regard we are need to hear your voice about the YMCS.
Please visit : http://forum.yealink.com/forum/showthread.php?tid=42322


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
NAPTR Defaulting to UDP, How to set TCP
Author Message
marcelm Offline
Junior Member
**

Posts: 4
Joined: Oct 2016
Reputation: 0
Post: #1
NAPTR Defaulting to UDP, How to set TCP
Hello,

As the subject describes, I'm working on setting up NAPTR with SRV records on a Yealink T27P. Everything seems to be working but the phone is defaulting to UDP transport and I need it to use TCP instead. I can't find anywhere to make this change. Is it possible to tell the phone to use TCP for NAPTR and SRV records?
10-05-2016 09:41 AM
Find all posts by this user    like0    dislike0 Quote this message in a reply
marcelm Offline
Junior Member
**

Posts: 4
Joined: Oct 2016
Reputation: 0
Post: #2
RE: NAPTR Defaulting to UDP, How to set TCP
Just following up with my post. From what I understand this is done with the NAPTR record, you set the pirority of the protocol. I've found the following instructions

http://download.support.yealink.com/down...Phones.pdf

In this document on page 12 it states:
Quote:The IP phone picks the first record, because its order of 90 is lower than 100. The pref parameter is unimportant as there is no other record with order 90. The flag "s" indicates performing the SRV query next. TCP will be used, targeted to a host determined by an SRV query of "_sip._tcp.yealink.pbx.com".

I am using Amazon Route 53 and I've setup my NAPTR and SRV records as follows

Code:
NAPTR
tennant1.server.com
90 50 "s" "SIP+D2T" "" _sip._tcp.tennant1.server.com

SRV
_sip._tcp.tennant1.server.com
0 2 5090 srv1.server.com.
0 1 5090 svr2.server.com.

Does anyone know if I am missing something?
10-05-2016 11:57 PM
Find all posts by this user    like0    dislike0 Quote this message in a reply
marcelm Offline
Junior Member
**

Posts: 4
Joined: Oct 2016
Reputation: 0
Post: #3
RE: NAPTR Defaulting to UDP, How to set TCP
So there seems to be a bug in the *.70 firmware that causes it to only register with UDP. Upgrading the firmware resolves this issue but also causes other issues.
(This post was last modified: 10-11-2016 03:16 AM by marcelm.)
10-11-2016 03:06 AM
Find all posts by this user    like0    dislike0 Quote this message in a reply
Karl_Yealink Offline
Super Moderator
******

Posts: 673
Joined: Apr 2015
Reputation: 3
Post: #4
RE: NAPTR Defaulting to UDP, How to set TCP
When you using the NAPTR, the transport don't up to phone.
It's up to NAPTR record.You can configure the priority, then the phone will choose TCP transport. The priority up to order parameter, the smaller parameter has higher priority.

There is another possibility, do you fill port as 0?
Please check the attach image.
If the port explicit, the phone use UDP as default transport.


Attached File(s) Thumbnail(s)
   
10-17-2016 10:39 AM
Find all posts by this user    like0    dislike0 Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Ringtone keep defaulting versus what we chose? strobesnmore 7 8,717 09-19-2014 08:59 AM
Last Post: pjetson

Forum Jump:


User(s) browsing this thread: 1 Guest(s)

Contact Us   Yealink   Return to Top   Return to Content   Lite (Archive) Mode   RSS Syndication