[YMCS/YDMP Free Trial Program]Yealink would like to offer Free Trial Program of Yealink device management service for our current eligible customers. You can see the details below.
https://www.yealink.com/ydmp-freetrial-2020


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
W52P Provision not working (FW 25.73.0.40)
Author Message
rdi Offline
Junior Member
**

Posts: 2
Joined: Mar 2016
Reputation: 0
Post: #1
W52P Provision not working (FW 25.73.0.40)
Hi all,

I'm the founder of FlexiPBX and want to use the W52P as the dect solution for my customers. I have a provisioning template based on the provided "Yealink W52P AutoProvisioning Template_V50" which is requested and deliverd by the web server but the W52P doesn't do anything.

I checked the pcap trace if the right content is delivered and it is:
   

I checked the log file in log level 6 and always get the same result.
"response process finish!"
"recv : 0 bytes"

Also if I get the local log from the W52P there are some strange *.pcap files and memcheck info files. (log attached)

here the log section:
Code:
Mar 22 10:35:37 Log [458]: WEB <6+info  > AutoProvision now
Mar 22 10:35:37 Log [458]: WEB <6+info  > Write autop config success!
Mar 22 10:35:37 ATP [400]: ATP <6+info  > Upgrade by default
Mar 22 10:35:37 ATP [400]: ATP <6+info  > Try upgrade by dhcp options
Mar 22 10:35:37 ATP [400]: ATP <6+info  > Upgrade by DHCP option Fail
Mar 22 10:35:37 ATP [400]: ATP <6+info  > Upgrade by static config
Mar 22 10:35:37 Log [422]: ETLL<6+info  >Processing message 0x30007 ...
Mar 22 10:35:37 Log [422]: CUIT<6+info  >TalkLogic: PHONE_MSG_GETWORKSTATUS[0][0]!
Mar 22 10:35:37 Log [422]: TALK<6+info  >talklogic_SessionExist [iSessionNum=0]
Mar 22 10:35:37 ATP [400]: ATP <6+info  > Upgrade from com.cfg
Mar 22 10:35:37 LIBD[400]: DCMN<6+info  > Connecting <provisioning url>:80
Mar 22 10:35:37 LIBD[400]: DCMN<6+info  > Connecting IP = <server IP>, Port = 80
Mar 22 10:35:37 LIBD[400]: HTTP<6+info  > Request Line: GET /provision/y000000000025.cfg HTTP/1.1^M
Mar 22 10:35:37 LIBD[400]: HTTP<6+info  > Host: <provisioning url>
Mar 22 10:35:37 LIBD[400]: HTTP<6+info  > User-Agent: Yealink SIP-W52P 25.73.0.40 00:15:65:96:ad:f7
Mar 22 10:35:37 LIBD[400]: HTTP<6+info  > process response
Mar 22 10:35:37 LIBD[400]: HTTP<5+notice> response code: 401
Mar 22 10:35:37 LIBD[400]: HTTP<6+info  > Chunked Encoding
Mar 22 10:35:37 LIBD[400]: HTTP<6+info  > http auth type: 1,
Mar 22 10:35:37 LIBD[400]: HTTP<6+info  > Cleaning cache
Mar 22 10:35:37 LIBD[400]: HTTP<5+notice> response code: 200
Mar 22 10:35:37 LIBD[400]: HTTP<6+info  > Content-Length: 19524
Mar 22 10:35:37 LIBD[400]: HTTP<5+notice> response process finish!
Mar 22 10:35:37 LIBD[400]: HTTP<5+notice> recv : 0 bytes
Mar 22 10:35:37 ATP [400]: ATP <3+error > Can't read 23 byte
Mar 22 10:35:37 ATP [400]: ATP <6+info  > need_cmp_md5=1
Mar 22 10:35:37 ATP [400]: ATP <6+info  > cfg md5 same!
Mar 22 10:35:37 Log [422]: ETLL<6+info  >Processing message 0x30007 ...
Mar 22 10:35:37 Log [422]: CUIT<6+info  >TalkLogic: PHONE_MSG_GETWORKSTATUS[0][0]!
Mar 22 10:35:37 Log [422]: TALK<6+info  >talklogic_SessionExist [iSessionNum=0]
Mar 22 10:35:38 ATP [400]: ATP <6+info  > Upgrade from mac.cfg
Mar 22 10:35:38 LIBD[400]: DCMN<6+info  > Connecting <provisioning url>:80
Mar 22 10:35:38 LIBD[400]: DCMN<6+info  > Connecting IP = <Server IP>, Port = 80
Mar 22 10:35:38 LIBD[400]: HTTP<6+info  > Request Line: GET /provision/00156596adf7.cfg HTTP/1.1^M
Mar 22 10:35:38 LIBD[400]: HTTP<6+info  > Host: <provisioning url>
Mar 22 10:35:38 LIBD[400]: HTTP<6+info  > User-Agent: Yealink SIP-W52P 25.73.0.40 00:15:65:96:ad:f7
Mar 22 10:35:38 LIBD[400]: HTTP<6+info  > process response
Mar 22 10:35:38 LIBD[400]: HTTP<5+notice> response code: 401
Mar 22 10:35:38 LIBD[400]: HTTP<6+info  > Chunked Encoding
Mar 22 10:35:38 LIBD[400]: HTTP<6+info  > http auth type: 1,
Mar 22 10:35:38 LIBD[400]: HTTP<6+info  > Cleaning cache
Mar 22 10:35:38 LIBD[400]: HTTP<5+notice> response code: 200
Mar 22 10:35:38 LIBD[400]: HTTP<6+info  > Content-Length: 43057
Mar 22 10:35:38 LIBD[400]: HTTP<5+notice> response process finish!
Mar 22 10:35:38 LIBD[400]: HTTP<5+notice> recv : 0 bytes
Mar 22 10:35:38 ATP [400]: ATP <3+error > Can't read 23 byte
Mar 22 10:35:38 ATP [400]: ATP <6+info  > need_cmp_md5=1
Mar 22 10:35:38 ATP [400]: ATP <6+info  > cfg md5 same!

the config is delivered but not applied to the W52P. Can anybody please help me with this issue?

Best regards,
Roman


Attached File(s)
.zip  log.zip (Size: 94.57 KB / Downloads: 6)
03-22-2016 08:49 PM
Find all posts by this user    like0    dislike0 Quote this message in a reply
Klaus_Yealink Offline
Super Moderator
******

Posts: 180
Joined: Jul 2015
Reputation: 0
Post: #2
RE: W52P Provision not working (FW 25.73.0.40)
From the log,we can find that "cfg md5 same!",so the phone will not update.

So I suggest you change some parameters,then test again.
03-23-2016 05:04 AM
Find all posts by this user    like0    dislike0 Quote this message in a reply
rdi Offline
Junior Member
**

Posts: 2
Joined: Mar 2016
Reputation: 0
Post: #3
RE: W52P Provision not working (FW 25.73.0.40)
(03-23-2016 05:04 AM)Yealink_Klaus Wrote:  From the log,we can find that "cfg md5 same!",so the phone will not update.

So I suggest you change some parameters,then test again.

I have changed the parameters several times in both y000000000025.cfg and {mac}.cfg files but I always get "cfg md5 same!". I also reset to factory defaults several times and started all over again. Didn't help. Also with the first provisioning attempt after a "reset to factory defaults" I get "cfg md5 same!". In the meanwhile I also could test another W52P and there I have the same issue.

On my T38G everything worked fine from the first provisioning attempt on!

Best regards,
Roman
03-23-2016 03:02 PM
Find all posts by this user    like0    dislike0 Quote this message in a reply
Klaus_Yealink Offline
Super Moderator
******

Posts: 180
Joined: Jul 2015
Reputation: 0
Post: #4
RE: W52P Provision not working (FW 25.73.0.40)
we will fix this issue in ticket 23531.
04-01-2016 08:07 PM
Find all posts by this user    like0    dislike0 Quote this message in a reply
samrh Offline
Junior Member
**

Posts: 3
Joined: Aug 2016
Reputation: 0
Post: #5
RE: W52P Provision not working (FW 25.73.0.40)
Where can I find this ticket, it seems that I have the same problem ?

(04-01-2016 08:07 PM)Yealink_Klaus Wrote:  we will fix this issue in ticket 23531.
08-25-2016 10:34 PM
Find all posts by this user    like0    dislike0 Quote this message in a reply
AndrewGold Offline
Junior Member
**

Posts: 5
Joined: Jul 2015
Reputation: 0
Post: #6
RE: W52P Provision not working (FW 25.73.0.40)
Hi All.

How can I get firmware fix for provisioning issue resolving?
(This post was last modified: 09-01-2016 08:50 PM by AndrewGold.)
09-01-2016 07:32 PM
Find all posts by this user    like0    dislike0 Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  W52P Firmware upgrade aunijaffer@gmail.com 5 1,274 09-07-2021 11:42 PM
Last Post: complex1
  W52P Repeater RT10/rt20/RT30 schnell-yealink 1 1,697 06-16-2021 02:55 AM
Last Post: complex1
  W52P 2 handsets DAZZLING 1 1,801 06-01-2021 09:55 PM
Last Post: complex1
  W52P Openvpn with mikrotik info@quantiss.com 4 10,138 04-11-2021 06:25 AM
Last Post: Harms_Kubiak
  Is there no call history in web management panel in W52P? poznaniak 1 3,562 08-10-2020 12:49 PM
Last Post: complex1
  W52P factory reset without password ralph 1 4,900 04-02-2020 03:05 AM
Last Post: Yisroel_MongoTEL
  W52p Repair Aliaksandr 10 14,667 02-10-2020 10:30 PM
Last Post: RobertoDSM
  Action URI in W52P RRC_Support 1 4,338 10-22-2019 01:27 PM
Last Post: Garry_Yealink
  W52P Sporadic behavior with auto answer csmith@ccexpert.net 2 8,928 09-27-2019 08:38 PM
Last Post: justingoldberg
  W52P Dect Interface "Settings" is missing ? CHRIYEA 1 4,510 06-06-2019 08:58 AM
Last Post: complex1

Forum Jump:


User(s) browsing this thread:

Contact Us   Yealink   Return to Top   Return to Content   Lite (Archive) Mode   RSS Syndication