Yealink Forums
BLF: unavailable state shown as idle - Printable Version

+- Yealink Forums (
+-- Forum: IP Phone Series (/forumdisplay.php?fid=4)
+--- Forum: T4x Series (/forumdisplay.php?fid=31)
+--- Thread: BLF: unavailable state shown as idle (/showthread.php?tid=894)

Pages: 1 2 3 4

BLF: unavailable state shown as idle - markino - 10-10-2013 05:51 AM

BLF key programmed to an extension.
If the extension is unavailable, the led stays solid green, no matter what. I've also tried to program an extension not configured in the pbx: solid green.
Every other state (idle, busy, hold, ring) is shown correctly.

RE: BLF: unavailable state shown as idle - Yealink Support - 10-10-2013 02:51 PM

Hi Markino,
Here i tried with, then fill a unavailable extention to BLF Value, and the LED is not solid green, just off.
When i fill a available extention, it will stay solid green.
Could you reset to factory default and check again? (Disabled "LED Off in Idle" in the webpage-Features-General Information)

RE: BLF: unavailable state shown as idle - Martijn - 10-10-2013 05:05 PM

Hello Yealink,

Just stumbled on the same issue here, when i change the extension to from available to unavailable the LED stays green, just updated to the last firmware. LED Off in Idle is disabled.


RE: BLF: unavailable state shown as idle - markino - 10-10-2013 10:54 PM

Reset to factory, reloaded config, no changes.

RE: BLF: unavailable state shown as idle - Yealink Support - 10-12-2013 03:19 PM

Hi Markino,

could you provide PCAP trace, syslog(level 6) and config.bin file to us, so we can analyze?
Before you export the syslog, please set log level as 6, and reboot the phone, then click Start,and reproduce the issue, then click Stop,and export the trace, syslog, config,bin to us.
(About where to export these files, please refer to attached screenshot.)
These three files are very important for us, hope you can kindly understand.

RE: BLF: unavailable state shown as idle - Martijn - 10-14-2013 07:18 PM

Just sent a private message to your account with requested data, if not received correctly please let me know.

Thanks in advance!

RE: BLF: unavailable state shown as idle - Martijn - 10-17-2013 07:31 PM

Are the files helpful? Do i need to send you some more?

Thanks in advance.

RE: BLF: unavailable state shown as idle - Yealink Support - 10-21-2013 09:53 AM

Hi Martijn,

I have submitted your issue to our R&D. If any update, i will contact you soon.
Thanks in advanced.

RE: BLF: unavailable state shown as idle - Yealink Support - 10-22-2013 05:38 PM

Hi Martijn,

Our R&D colleague finds the probable reason of this issue.
1.LED Off in Idle is disable, if monitored account is idle, LED stays green as designed. Only when NOTIFY message contains"Subscription-State:terminated", then LED will off.
2.T46G doen't receive the NOTIFY message contains “Subscription-State:terminated”, so LED will stay green.
3.In the application scenario, server will send NOTIFY message contains “Subscription-State:terminated” when account is cancelled, then LED of BLF will off. Otherwise, LED will stay green. So please check about the corresponding settings in server.

RE: BLF: unavailable state shown as idle - Martijn - 10-23-2013 07:05 PM

Hello Yealink,

Thanks for your information and looking into it, just received another T46G for being able to test if it is functioning properly between two of the same phones.

When i set 9999001 extention to DND, i will get the Subscription-State:Terminated, and the LED will become RED.

But when disabling the account on the phone it self, or pulling out the network connection i will get no change on the LED (stays green), and i get the following output:

[undefined=undefined][2013-10-23 12:22:21] NOTICE[18924]: chan_sip.c:29376 sip_poke_noanswer: Peer '9999001' is now UNREACHABLE!  Last qualify: 50
Really destroying SIP dialog '3c90230240e09a2729ba42ee401c1384@xxxxxxxx:5060' Method: OPTIONS
set_destination: Parsing <sip:12345@> for address/port to send to
set_destination: set destination to
Reliably Transmitting (NAT) to xxxxxxxx:5063:
NOTIFY sip:12345@ SIP/2.0
Via: SIP/2.0/UDP xxxxxxxx:5060;branch=z9hG4bK10856aa9;rport
Max-Forwards: 70
From: <sip:9999001@xxxxxxxx>;tag=as350e2ecc
To: "Test" <sip:12345@xxxxxxxx>;tag=1217145946
Contact: <sip:9999001@xxxxxxxx:5060>
Call-ID: 696061064@
CSeq: 119 NOTIFY
User-Agent: -2.11.0beta2(11.6.0)
Subscription-State: active
Event: dialog
Content-Type: application/dialog-info+xml
Content-Length: 212

<?xml version="1.0"?>
<dialog-info xmlns="urn:ietf:params:xml:ns:dialog-info" version="17" state="full" entity="sip:9999001@xxxxxxxx">
<dialog id="9999001">

  == Extension Changed 9999001[ext-local] new state Unavailable for Notify User 12345

<--- SIP read from UDP:xxxxxxxx:5063 --->
SIP/2.0 200 OK
Via: SIP/2.0/UDP xxxxxxxx:5060;branch=z9hG4bK792f3c24;rport
From: <sip:9999001@xxxxxxxx>;tag=as531756ea
To: "Test" <sip:12345@xxxxxxxx>;tag=499743169
Call-ID: 786499161@
CSeq: 108 NOTIFY
Contact: <sip:12345@>
User-Agent: Yealink SIP-T46G
Content-Length: 0

Is this Asterisk thats not sending this NOTIFY properly? But of what i can find this should be the normal way of doing this?

Thanks in advance,