Yealink Forums
Auto-answer via SIP-header - Printable Version

+- Yealink Forums (
+-- Forum: Dect Phone Series (/forumdisplay.php?fid=6)
+--- Forum: W52P (Wireless) (/forumdisplay.php?fid=23)
+--- Thread: Auto-answer via SIP-header (/showthread.php?tid=811)

Auto-answer via SIP-header - mkeuter - 09-21-2013 07:10 PM

Is an auto-answer feature via SIP-header for the W52P possible, similar to the T-2xP/T-3xP series?

SIPAddHeader(Call-Info: <sip:pbx-ip>\;answer-after=0)

I ask because I want that to use for Click2Dial (CTI) application (routed over a special CTI context for security reasons of course). And also for paging.

RE: Auto-answer via SIP-header - Yealink Support - 09-23-2013 02:13 PM

Hi Mkeuter,
W52P use the same SIP as T2/T3 series. So you can have a try "answer-after=0".

RE: Auto-answer via SIP-header - mkeuter - 09-23-2013 11:58 PM

Thanks, good to know.

Update: after an upgrade to FW it works fine now for me.

RE: Auto-answer via SIP-header - sunstatetech - 04-01-2014 02:19 AM

Sorry to bring this thread back, but I figured it was better to keep all this info in one place instead of starting a new thread.

I am using this SIP TAPI:

Everything works great, but I can't seem to get auto answer to work with a T46G ( This SIP TAPI provider has two configuration options for auto answer:

[Image: r1EeFZP.png]

I have tried both options and neither works. I have taken a capture on the phone for each auto answer option, but I can't find Call-Info anywhere in the message header.

[Image: nMnpDdU.png]

Where should the Call-Info be? If it is not there, I'm guessing this means that the SIP TAPI isn't sending it, or that the PBX (3CX) is stripping it?

Thanks in advance.

RE: Auto-answer via SIP-header - Yealink Support - 04-02-2014 04:11 PM

Call-info: answer-after=0 should be sent by PBX usually. You can refer to 3CX technical specialist for more details.

RE: Auto-answer via SIP-header - mkeuter - 04-02-2014 11:00 PM


I use a special context "auto-answer" in Asterisk, where I add the SIP-header (and then dial the phone). Then I point the dialer application to the device e.g. "local/100@auto-answer" instead of "SIP/100". But interestingly it works for me for both snom and Yealink phones. No idea if this approach would work for 3CX as well …


RE: Auto-answer via SIP-header - Walter - 04-29-2014 12:08 AM

Dear sunstatetech,
I'm using the siptapi 0.2.15 too.
Please select Polycom, SNOM-old, instead Siemens,SNOM-New
The first option works well with ALL Yealink models
Bye Walter