Yealink Forums
T46G TIME Calculation Problem - Printable Version

+- Yealink Forums (
+-- Forum: IP Phone Series (/forumdisplay.php?fid=4)
+--- Forum: General topics (/forumdisplay.php?fid=15)
+--- Thread: T46G TIME Calculation Problem (/showthread.php?tid=669)

T46G TIME Calculation Problem - briankelly63 - 07-25-2013 11:07 AM

I first noticed this because the call history was showing calls as "YESTERDAY" even though they were just received.

The problem affects both manual and automatic time setting but differently.

To see the issue go to Settings->Time & Date
then Enable "Manual Time".

You will be unable to set the time to 23 hours. It will change to 0

If you set it for 22 and save it the display will show 23. Set it to 21 it will show 22.

Internally this error corrupts the calculation from the time server and DST and because of that calls in the "History" log of the phone will show as "YESTERDAY".

There really is no work around unless you want to set the wrong time.

RE: T46G TIME Calculation Problem - Yealink Support - 07-25-2013 02:17 PM

Hi Brian,
What's the firmware are you using?
Here i am use the firmware, and it works well.
Could you check again?

RE: T46G TIME Calculation Problem - VIDEO sent to Support - briankelly63 - 07-25-2013 08:54 PM

This is a nasty little bug that changes depending what you do in the UI screen. It is also dependent on whether the phone is configured or not.

I am using the same firmware as you.

If I try and set the values to the same exact values that are included in your picture and then hit Confirm two things happen. The first is that the day changes from 25 to 26 and the Hour changes to 0.

Please look at the attachment.

I just tried the same thing with another T46G running the same firmware and it INITIALLY it worked properly.

BUT If you change the DHCP Time setting on the time screen or change the Date Format from YYYY-MM-DD to WWW-MM-DD and then try to store a 23 in the hour box lots of strange things start to happen

So I did a factory reset on the phone in question and then re-tested. The time setting then works correctly BUT If I Import the previously Exported configuration the problem returns.

So it would seem there is a corruption issue that is preserved during an Export - Import.

I did another factory reset but DID NOT reload my configuration. In this case the settings work properly and the UI allows me to set 23 as the hour no matter what the other settings happen to be.

I will send you the config.bin that I am using so you can load it and test what is happening.

Something is being corrupted by my configuration. The only unusual thing in my configuration is that I have a VPN file set loaded. It is NOT enabled but it is loaded.


RE: T46G TIME Calculation Problem - Yealink Support - 07-31-2013 03:55 PM

Hi Brain,
Thanks for your config.bin and video, support.usa guy already submit this to R&D, any update they will let you know.

RE: T46G TIME Calculation Problem - rrnworks - 11-24-2014 08:37 AM

We're seeing the same problem on a brand new yealink T42G - the time on the phone shows correctly but all outgoing and incoming calls show YDay in the History (even though they were made today)?

RE: T46G TIME Calculation Problem - jeanpierre26 - 12-06-2021 10:09 AM


I'm having the same problem here in Australia (time zone +10)
In the history screen calls are shown as yesterday instead of today.

Was there any resolution for this issue?

We have T29G phones fw, using DHCP and NTP for time server

Please let me know