Yealink Forums
W52 handset firmware update - Printable Version

+- Yealink Forums (
+-- Forum: Dect Phone Series (/forumdisplay.php?fid=6)
+--- Forum: W52P (Wireless) (/forumdisplay.php?fid=23)
+--- Thread: W52 handset firmware update (/showthread.php?tid=497)

Pages: 1 2

W52 handset firmware update - Barnabas - 05-28-2013 02:40 PM


How can I upgrade the firmware on the W52P handset? I downloaded handset firmware I opened the battery compartment and connected the USB port to my computer which is running Windows 7 66-bit service pack-1. Bit I got an error message that the USB device is not recognized.

Could someone please point me to the correct USB driver and possibly the instructions on how to update handset firmware?

Thank you,

RE: W52 handset firmware update - Yealink Support - 05-29-2013 02:40 PM

Hi Barnabas,
Could you let me know where do you download the handset version? Generally user don't need to upgrade the handset.
But i prepare some video, manual for you, about how to upgrade the handset, please download them as below link:
Please try.

RE: W52 handset firmware update - Barnabas - 05-29-2013 03:59 PM

Thank you Administrator,

I downloaded the firmware initially from

I downloaded both versions of the flashers; 64-bit and 32 from your provided link. I tried both of them but they could't detect the handset. I tried "Scan device" but that didn't help either.

When I plug in the USB cable, my Windows 64 (SP-1) says "New hardware detected" but then gives an error that "USB device not recognized".

I unplugging and plugging the USB cable several times. Then I removed the failed driver from the hardware list (Computer manager) but it didn't help. Windows detects it as either an "Unknown Device" under USB controller, or a "USB-DECT" under other devices. In either case there is a yellow error sign next to the failed device driver name.

I tried it on Windows XP SP-3 but I had the same errors when I plugged the USB cable.

It seems that Windows needs to detect it first and load the drivers properly before the flasher can list it.

Is there s USB driver available? What operating system was used in the video tutorial?

Thank you,

RE: W52 handset firmware update - Yealink Support - 06-04-2013 03:57 PM

Hi Barnabas,
It's Win 7 32 system in the video, and it can be supported by win 7 64/32 and win XP system.
I put the driver "usbser.sys" to this link:
Please check again.
And actually we are not suggest customer to upgrade the handset, if there's no problem, you don't need to upgrade it.

RE: W52 handset firmware update - Barnabas - 06-05-2013 02:33 AM

Thank you Administrator.

Certainly; we won't upgrade if there is no need to. However we need to test the process at our "validation" stage before releasing it to our customers.

I downloaded usbser.sys but not sure how to install it. I tried adding a new USB controller device but Windows only allows ini type files. Will you please advise how to install it?

Thank you,

RE: W52 handset firmware update - Yealink Support - 06-05-2013 04:58 PM

Hi Barnabas,
1. Please put "usbser.sys" into this path in your computer.
Then active your handset(have back light) and connect to PC.
And try again with W52p-Flasher.exe tool.
2. If the problem is still, please right click W52p-Flasher.exe, and run as administrator, it will install the driver.

RE: W52 handset firmware update - Barnabas - 06-06-2013 02:20 AM

It worked so perfectly well! I ran it as administrator and the driver installation popped up and installed. Then the device showed up on the list. Our test-upgrade completed as planned.

Thank you very much!

RE: W52 handset firmware update - Yealink Support - 06-06-2013 11:10 AM


RE: W52 handset firmware update - Yealink Support - 06-08-2013 10:19 AM

Hi Barnabas,
Are you from Australia? Is there any project you are running? If yes, i can introduce our sales and special professional technical engineer to support you effectively. You can share your project information for us by priviate message, or send it to our
Thanks. Smile

RE: W52 handset firmware update - Barnabas - 06-08-2013 01:19 PM

Hi Administrator,

I work for Authoritel which is headquartered in San Jose, CA, USA.
FYI I'm working on SIP-T4x series. The configuration parameters are not accurate in the Admin Manual. I'm creating a working MAC file and Yx.cfg file.