Yealink Forums
MP50 Phones not dialling - Printable Version

+- Yealink Forums (
+-- Forum: IP Phone Series (/forumdisplay.php?fid=4)
+--- Forum: General topics (/forumdisplay.php?fid=15)
+--- Thread: MP50 Phones not dialling (/showthread.php?tid=45944)

MP50 Phones not dialling - - 07-20-2022 04:10 PM

Hello Everyone

We have several teams and they work fine on the PCs /Laptop When using a MP50 the account comes up with no problems but when dialing on the phone nothing happens.

ANY HELP ?? We install teams on a NEW laptop and deleted all ref regarding the Linc in the Hkey\local User
uninstalled teams - reinstalled teams - rebooted

still the same
- Gone through this too
has any one fixed it

RE: MP50 Phones not dialling - LboroGaryP - 07-28-2022 04:39 PM

(07-20-2022 04:10 PM) Wrote:  We have several teams and they work fine on the PCs /Laptop When using a MP50 the account comes up with no problems but when dialing on the phone nothing happens.

Hi, we have a few WH66 headsets (basically an MP50 with a DECT headset rather than a handset) and have exactly the same issue on PC and Mac.

There seems to be *some* communication between the device and the Teams client on my Mac as the device shows my name, I can press the Teams button to to bring the client to the foreground on my Mac, and call control seems to work, but the dialpad never starts a call.

As an aside, when trying to place a call from the device's dialpad I often see heightened CPU use from Teams processes, and the Teams client becomes unresponsive.

It's a shame as the devices look good on paper, but this doesn't make the MS certification program look great.

RE: MP50 Phones not dialling - - 08-07-2022 01:22 AM

We also have this problem. The functionality of Teams is great, but when someone tries to use a MP50, it will do everything but actually dial out. This defeats the purpose of having a "desk" phone for use...Anyone else heard any fixes or ideas other than what is listed? We have tried them all...

RE: MP50 Phones not dialling - - 08-15-2022 08:02 PM

Just created a ticket with support before i found this thread, but I have the same issue. I also dont understand that it can get a Teams certification with such a basic feature not working. Everything but dial out from the phone itself seems to be working.
Which fixes has already been listed?

RE: MP50 Phones not dialling - - 08-24-2022 03:45 AM

Has anyone found a fix for this yet. I'm trying to evaluate phones for when we switch over to a Teams phone system and so far this issue has turned me away from the Yealink brand.

RE: MP50 Phones not dialling - - 08-24-2022 03:54 AM

Yealink Tech Support has told me it is a Microsoft issue, and the Microsoft Update for September supposedly should fix it...maybe...we will see...

RE: MP50 Phones not dialling - - 08-25-2022 05:31 PM

I was also told that Microsoft is supposed to fix this in their next update. I started out testing Better Together with Yealink MP54, MP58 and VP59, but there are a bunch of issues with outgoing video and, Better Together automatically sets the phone as camera in Teams, so the non camera models are pretty much useless. I then choose MP50 USB as the last resort - thinking this could not go wrong...
Anyone else having experience with Better Together, because I just dont understand it, and it seems to be abandonded by MS.

RE: MP50 Phones not dialling - Oksania - 09-23-2022 09:35 PM


I recently deployed some Yealink MP50 USB phone devices to my agency users who are on Teams Voice. For some, the MP50 works perfectly: plug and play and away we go.
Unfortunately, for most users they can't start, answer, or end calls but the pause/resume and mute/unmute work fine during a call.
- If they start a call from the phone's controls it looks like it is attempting to dial out but nothing happens on the PC and it eventually ends
- If they receive a call it shows up on the MP50's screen but the answer and decline buttons do not work and neither does pressing speakerphone or picking up the handset.
- If a user starts or answers a call on the PC they can use the MP50 for microphone and audio
- Picking up the handset switches it from speakerphone to handset,
- If I do a test call on the troubled setup, Teams displays a banner saying "No device call controls. Exit other calling apps so you can use your device call controls with teams.
To me, this eliminates the possibility of the device, the PC, the Teams accounts, and the Domain account from being the issue and just leaves it to being an issue with the local Windows profile on the PC.

I hope someone can provide some other troubleshooting options. I may have to look at alternatives, but what from I've seen it sounds like most other phones run Teams as a separate instance, creating several other drawbacks, or else have to be dumbed down to operate similar to the MP50 which makes them a waste of money.