Yealink Forums
Yealink T46G+T48G with EHS & Jabra Suddenly Switches to "Off Hook", or disconnects - Printable Version

+- Yealink Forums (http://forum.yealink.com/forum)
+-- Forum: IP Phone Series (/forumdisplay.php?fid=4)
+--- Forum: T4x Series (/forumdisplay.php?fid=31)
+--- Thread: Yealink T46G+T48G with EHS & Jabra Suddenly Switches to "Off Hook", or disconnects (/showthread.php?tid=41879)



Yealink T46G+T48G with EHS & Jabra Suddenly Switches to "Off Hook", or disconnects - Complea_KJM - 06-08-2018 08:06 AM

Hi
We are experiencing some issue at a Customer.
They are using Yealink T46G & T48G with EHS36 and Jabra 920Pro headsets.
When the headset is in the base, suddenly the phone looks like it is "Off Hook", and after a couple of seconds it switch back to idle (We also experience this at our Office with T46G+EhS36+Jabra Pro9470).
Related to this, it sometimes messes up the "Sync" between headset and phone, and the headset base thinks it is off hook, and the phone is on hook. When you then try to answer a call/activate headset, it hangs up, and vice versa.

They are also experiencing calls suddenly getting disconnected. When we run traces on the system, we get a correct "200 BYE" command from the phone, but the user hasn't hung up, making us believe this is related to the headset issues, and the headset ends the call, causing the phone send a "200 BYE".
We have tried switching headset (They used Jabra/GN9330 before), replaced the EHS36, and replaced the Phone. It is happening randomly.

Phones are running latest firmware (xx.83.0.35), EHS36 is firmware 4.16.0.0, and headset are running latest firmware.
Phones is connected to PoE and PBX is 3CX v15.5SP4.

Do you have any suggesitions on hand, or what king of logs do you need to investigate further?


Yealink T46s with EHS & Jabra Suddenly Switches to "Off Hook", or disconnects - edp4you - 12-10-2018 09:05 AM

(06-08-2018 08:06 AM)Complea_KJM Wrote:  Hi
We are experiencing some issue at a Customer.
They are using Yealink T46G & T48G with EHS36 and Jabra 920Pro headsets.
When the headset is in the base, suddenly the phone looks like it is "Off Hook", and after a couple of seconds it switch back to idle (We also experience this at our Office with T46G+EhS36+Jabra Pro9470).
Related to this, it sometimes messes up the "Sync" between headset and phone, and the headset base thinks it is off hook, and the phone is on hook. When you then try to answer a call/activate headset, it hangs up, and vice versa.

They are also experiencing calls suddenly getting disconnected. When we run traces on the system, we get a correct "200 BYE" command from the phone, but the user hasn't hung up, making us believe this is related to the headset issues, and the headset ends the call, causing the phone send a "200 BYE".
We have tried switching headset (They used Jabra/GN9330 before), replaced the EHS36, and replaced the Phone. It is happening randomly.

Phones are running latest firmware (xx.83.0.35), EHS36 is firmware 4.16.0.0, and headset are running latest firmware.
Phones is connected to PoE and PBX is 3CX v15.5SP4.

Do you have any suggesitions on hand, or what king of logs do you need to investigate further?

Hi Complea_KJM,
we are experiencing the same issue with Yealink T46S fw xx.83.0.55. with EHS36 fw 4.16.0.0.
We suspect that the component responsible for this behavior is the EHS.
On Yealink's support page for this component there is a firmware upgrade (v3.1), that upgrades EHS firmware to v5.16.0.0 but to upgrade the EHS36, we must downgrade the firmware of the phone to v xx.82.0.200.
Unfortunately our model of phone (T46S) is on firmware version xx.83.0.55 which cannot be downgraded to any of the previous versions (this is documented here: https://www.3cx.com/community/threads/yealink-firmware-upgrade-downgrade.61221/).
So our only choice is to send the ehs36 back to the reseller for an upgrade to V.5.16.0
I will be back as soon as I have further info.

Antonino Sbriglio.
Senior System Engineer EDP4You


Solution to Jabra Suddenly Switches to "Off Hook", or disconnects - edp4you - 01-09-2019 09:55 AM

Finally we have good news. The Yealink distributor for our country (Allnet, Italy) provided us a new firmware (xx.83.0.199) that we were able to flash on the T46S.
This version of firmware doesn't include the feature to update the EHS36, but unlocks the ability to downgrade the phone to a previous firmware version (that's where we were stuck).
So the next steps were:
- reflash the T46S with the right firmware (xx.82.0.200)
- upgrade the EHS36 switch to fw v. 5.16.0

After 2 weeks of intense use, I can confirm that the issue has been resolved, proving the fact that the cause was the buggy 4.16.0 firmware.

We hope our experience can help everyone who is incurring in the same problem.