Yealink Forums
Auto Provision after firmware update - Printable Version

+- Yealink Forums (http://forum.yealink.com/forum)
+-- Forum: IP Phone Series (/forumdisplay.php?fid=4)
+--- Forum: Auto Provisioning (/forumdisplay.php?fid=14)
+--- Thread: Auto Provision after firmware update (/showthread.php?tid=41423)



Auto Provision after firmware update - nickmancini - 12-28-2017 06:29 PM

Greetings everyone.

I have about 750 T41 phones using a wide range of firmware. I need to get all phones' firmware updated in order to perform an upcoming PBX upgrade.

I'm able to successfully perform the firmware upgrade by changing option-66 from the standard provisioning string, to to a firmware server, which has a y000000000036.cfg file, which contains the URL of the .rom file. (i.e., firmware.url = http://xxx.xxx.xxx.xxx/fw/T41-36.80.0.95.rom"

This part works great! If a phone was provisioned, it keeps it's config after the firmware update, and all is well.

What I am unable to do is have unprovisioned phones auto-provision after the firmware update is complete.

Unprovisioned (or factory reset) phones stop after they download & install the firmware.

I was advised to add the line:

"auto_provision.server.url = http://xxx.xxx.xxx.xxx/standard_prov_string"

which is the standard auto-provisioning string I normally use in option-66.

This results in the phones' GUI showing the proper provisioning url in the "Server URL" field, but, nothing happens.

Further, clicking "autoprovision now" or rebooting the phone does not work either.

The only way, so far, to have the phones provision after the firmware update is to change option-66 back to the provisioning string, and bounce the phone.

Any ideas on how to accomplish this without having to change option-66 back & forth?

Thanks!


RE: Auto Provision after firmware update - Lucia_Yealink - 12-29-2017 02:53 AM

Dear Customer,

Happy new year.

From your description, after you add the parameter:"auto_provision.server.url = http://xxx.xxx.xxx.xxx/standard_prov_string" into the CFG file, you can see the phone get the auto provision URL, and it show in the Server URL field in the WUI. Then we can confirm the auto provision with the option 66 works well.

But even you press Auto provision now in the WUI, it still failed. Then it may be the URL problem.

Please make sure there are auto provision files in the server. There is one way you can double check this: copy the URL to the broswer to check if you can reach the files, and let me know the result.

If still have problem, please provide the level 6 syslog, config.bin and pace trace(Refer to the FAQ to collect the three files:http://support.yealink.com/faq/faqInfo?id=707 ) when you do auto provision with the URL you want the phone do by press auto provision now option.

Please also provide the auto provision files for me.

You can send it to my email:Lucia@yealink.com

Best Regards,
Lucia