Yealink Forums
Bad sound with Opus - Printable Version

+- Yealink Forums (
+-- Forum: IP Phone Series (/forumdisplay.php?fid=4)
+--- Forum: General topics (/forumdisplay.php?fid=15)
+--- Thread: Bad sound with Opus (/showthread.php?tid=41372)

Bad sound with Opus - TrK - 12-08-2017 10:53 AM

I have several T21P E2 and T40P phones with latest firmware 82.0.20, Asterisk 14 (FreePBX 14 actually, installed with Asterisk 13, upgraded to Asterisk 14 with asterisk-version-switch) and lot of W56 handset (no Opus support yet). I use Asterisk PJSIP driver for my Yealink phones.
Opus was enabled everywhere and also set as primary codec. Asterisk console show calls established using opus (with opus->slin and slin->opus conversion actually).
In phones Opus enabled with autoprovision:
account.1.codec.opus.enable = 1
account.1.codec.opus.priority = 0
account.1.codec.opus.rtpmap = 107

But voice sound as ... corrupted? Some scratches and crackles, you know.
First I blamed bad network connection, but it was not true - even phones in same LAN have this issue.
I tried to update Opus - download latest codec from Digium and install it to Asterisk. No luck, voice still bad.
I tried to disable Opus in PBX and replace it with G722 - sound become much better!

Should i stay with G722 for now or die trying try to solve this issue somehow?