Yealink Forums
Error installing own server certificate - Printable Version

+- Yealink Forums (
+-- Forum: Dect Phone Series (/forumdisplay.php?fid=6)
+--- Forum: W56P(Wireless) (/forumdisplay.php?fid=57)
+--- Thread: Error installing own server certificate (/showthread.php?tid=41226)

Error installing own server certificate - flex - 10-20-2017 09:44 AM


i've created own server certificates for several SIP-T46S according to the guide "Using Security Certificates on Yealink IP Phones_V80_96.pdf". That means i've created a *.pem file containing key+certificate and installed my company CA under "Trusted Certificates". With the T46S everything works fine so if i access https://myt46s i see my own certificate. Exactly the same does not work for the shiny new W56P with all firmware updates applied (base+handset). The certificate gets imported and listed under "Server Certificate", but after rebooting the phone, i still see the generic Yealink certificate.

Whenever i import my own server certificate, syslog prints the following line

"LIBD[850]: DCMN<3+error > file can't be opened"

though correctly listed under "Security->Server Certificates"

As i've tried several combinations, did multiple factory resets and it still doesn't work, could you please check if there is an issue with own server certificate import on the latest firmware?

Thanks, flex