Yealink Forums
T41P: Call Park Problem - Printable Version

+- Yealink Forums (http://forum.yealink.com/forum)
+-- Forum: IP Phone Series (/forumdisplay.php?fid=4)
+--- Forum: T4x Series (/forumdisplay.php?fid=31)
+--- Thread: T41P: Call Park Problem (/showthread.php?tid=41002)



T41P: Call Park Problem - SFA1492 - 07-19-2017 04:31 PM

Hi,

I am having some difficulties to make "Call Park" work on my T41P.
The phone has "Call Park Mode" set to "Transfer", "Call Park" is "Enabled", "Call Park Code" is set to "*21" and "Park Retrieve Code" is set to "**21".

When I receive a call which I would like to put into a queue by pressing "Park" my display will show "Transferred" for a fraction of a second and hangs up. So far so good. But the caller gets disconnected - not so good.
If I do it manually by pressing "Transfer" followed by "*21" it takes a second, I get a positive feedback tone from my PBX, my phone hangs up and the caller gets into the queue.
It works the same way if I program a DSS Key as a Transfer-Button and put "*21" in as Value. After a second I get a positive feedback tone from my PBX, my phone hangs up and the caller gets into the queue.

Once I have a caller in my queue I can get him back by pressing a DSS Key programmed as "Park retrieve". So that at least works with my PBX.

Since the manual way works and the park procedure should the same thing - accoording to my understanding - I assume the the problem is located on the phone.
Is it possible that there is a firmware bug responsible for the behaviour. Installed version is 36.81.0.110.


RE: T41P: Call Park Problem - SFA1492 - 07-22-2017 09:24 AM

After a few more tests I figured out, that it is probably not a firmware bug.
The phone is simply too fast closing the connection after sending the call park code.
Like I mentioned above my PBX returns a positive feedback tone after about a second or so and than hangs up, when I park a call by pressing "Transfer" and enter the park code manually.
If I go the manual way and hang up before my PBX returns the feedback tone I get exactly the same behaviour when I use the predefined park button.

So the question at hand is: Is there a possibility (like adding a character to the call park code) to make the phone not to hang up or at least to delay the hang up, so the PBX has time to do what it has to do to park the call?


RE: T41P: Call Park Problem - Samuel_Yealink - 07-25-2017 01:17 PM

(07-22-2017 09:24 AM)SFA1492 Wrote:  After a few more tests I figured out, that it is probably not a firmware bug.
The phone is simply too fast closing the connection after sending the call park code.
Like I mentioned above my PBX returns a positive feedback tone after about a second or so and than hangs up, when I park a call by pressing "Transfer" and enter the park code manually.
If I go the manual way and hang up before my PBX returns the feedback tone I get exactly the same behaviour when I use the predefined park button.

So the question at hand is: Is there a possibility (like adding a character to the call park code) to make the phone not to hang up or at least to delay the hang up, so the PBX has time to do what it has to do to park the call?

Dear User,
Thanks for your detailed discription.
I tried the same operation here on my T41P however I didn't experience this problem.
Regarding this issue, would you please reproduce this issue(park the call by pressing the park button) and then send us the config.bin file, pcap trace file and syslog on level 6 so I can look into it?
Please refer this FAQ on how to get these files.
http://support.yealink.com/faq/faqInfo?id=313
Kind Regards
Samuel Wang


RE: T41P: Call Park Problem - SFA1492 - 07-25-2017 08:37 PM

Since my last test I don't think it is a phone issue, so I don't expect that you will be able to get the same result unless you use the same IP-PBX.
As an attachment I am sending the requested diagnostic files exported right after a "failed" park of a call.
If you address the problem I think it would be best if there would be an additional option if the phone should hang up after parking the call or not. In my case it doesn't have to. After the PBX is done parking the call it disconnects the phone anyways.


RE: T41P: Call Park Problem - Samuel_Yealink - 09-06-2017 03:01 PM

Dear User,

This is an issue with the PBX server end, please check it with your PBX service provider if it is configurable on the PBX end.

Kind Regards
Samuel Wang