Yealink Forums
T46G 28.81.0.110 not applying distinctive ringer tones correctly from provisioning - Printable Version

+- Yealink Forums (http://forum.yealink.com/forum)
+-- Forum: IP Phone Series (/forumdisplay.php?fid=4)
+--- Forum: T4x Series (/forumdisplay.php?fid=31)
+--- Thread: T46G 28.81.0.110 not applying distinctive ringer tones correctly from provisioning (/showthread.php?tid=40905)



T46G 28.81.0.110 not applying distinctive ringer tones correctly from provisioning - tima - 06-06-2017 03:52 PM

Hello,

Since upgraded to 28.81.0.110 the distinctive_ring_tones_alert_info ringer ins't being set when pushed from provisioning server.

I'm sending:

distinctive_ring_tones.alert_info.1.text = inbound-call
distinctive_ring_tones.alert_info.1.ringer = 4-Ring4.wav


In previous versions (and in 28.81.0.110 UI it shows this as correct) and it is applying the text but not the ringer. (showing as default 1-Ring1.wav in UI and being set to that when someone calls)

Attachments are from Settings > Ring before provisioning and after provisioning. You can clearly see that the text is being set but the Ringer File is not.


RE: T46G 28.81.0.110 not applying distinctive ringer tones correctly... - complex1 - 06-06-2017 04:12 PM

Hi tima,

Please change your template as follows:

Code:
# Configure the text to map the keywords contained in the "Alert-info" header
# distinctive_ring_tones.alert_info.X.text = family
distinctive_ring_tones.alert_info.1.text = inbound-call

# Specify the ring tone for each text. It ranges from 1 to 8. The default value 1 stands for Ring1.wav
# 1-Ring1.wav, 2-Ring2.wav, 3-Ring3.wav, 4-Ring4.wav, 5-Ring5.wav, 6-Ring6.wav, 7-Ring7.wav, 8-Ring8.wav.
# distinctive_ring_tones.alert_info.X.ringer = 1
distinctive_ring_tones.alert_info.1.ringer = 4



RE: T46G 28.81.0.110 - Samuel_Yealink - 06-07-2017 11:41 AM

(06-06-2017 03:52 PM)tima Wrote:  Hello,

Since upgraded to 28.81.0.110 the distinctive_ring_tones_alert_info ringer ins't being set when pushed from provisioning server.

I'm sending:

distinctive_ring_tones.alert_info.1.text = inbound-call
distinctive_ring_tones.alert_info.1.ringer = 4-Ring4.wav


In previous versions (and in 28.81.0.110 UI it shows this as correct) and it is applying the text but not the ringer. (showing as default 1-Ring1.wav in UI and being set to that when someone calls)

Attachments are from Settings > Ring before provisioning and after provisioning. You can clearly see that the text is being set but the Ringer File is not.

Hi Tima,
This is Samuel from Yealink Support Team, and it’s my pleasure to answer this question.
I think above solution from complex1 will solve your issue, would you please have a try and let me know how it works?
Kind Regards
Samuel Wang


RE: T46G 28.81.0.110 not applying - tima - 06-07-2017 01:46 PM

That did work but you may want to update the UI text which currently says:

The value "4-Ring4.wav" worked previously, now the value simply "4" is needed

Tim


Current UI text:

Description:
It configures the desired ring tone for each internal ringer text.
CFG Configuration:
distinctive_ring_tones.alert_info.1.ringer
Valid Value:
(1-Ring1.wav;2-Ring2.wav;3-Ring3.wav;4-Ring4.wav;5-Ring5.wav; 6-Ring6.wav;7-Ring7.wav;8-Ring8.wav;9-Silent.wav;10-Splash.wav)


RE: T46G 28.81.0.110 not applying distinctive ringer tones correctly from provision - blakeflorin - 06-07-2017 08:05 PM

All the popup help is in that format..... You use the number and discard the - and anything after. Threw me off also when i first started playing w the options.