Yealink Forums
autoprovision VPN - $MAC - Printable Version

+- Yealink Forums (http://forum.yealink.com/forum)
+-- Forum: IP Phone Series (/forumdisplay.php?fid=4)
+--- Forum: T4x Series (/forumdisplay.php?fid=31)
+--- Thread: autoprovision VPN - $MAC (/showthread.php?tid=40896)



autoprovision VPN - $MAC - blakeflorin - 06-05-2017 03:43 AM

Been screwing around for three days trying to figure this out. Finally see what its doing. I've gone through the latest three firmware versions for the T48G, all the same. Every other parameter I've used the $MAC wildcard in works correctly....except auto provisioning a VPN.

OpenVPN included in Freepbx drops each phones vpn file in the root of the tftp directory. Filename is formatted $MAC-vpn.tar. Manually uploading this file to the web interface works.

static.openvpn.url = tftp://##.###.##.7/$MAC-vpn.tar
^ the phone will download the file, even compares MD5 against the existing vpn file in its slot, but bombs out trying to start the connection.

I manually created a sub folder off the root using a mac address, renamed the file to remove the wildcard option.
static.openvpn.url = tftp://##.###.##.7/$MAC/open-vpn.tar
^ the phone downloads the file, compares and starts right up.

Also tried another variation-
static.openvpn.url = tftp://##.###.##.7/$MAC.tar
^ the phone downloads the file, compares and bombs out.

I would call this a bug between the file upload handler and starting the connection.

Maybe there's some option to make this work using " " or <MAC>, ??


RE: autoprovision VPN - $MAC - Paul_Yealink - 06-07-2017 03:06 AM

(06-05-2017 03:43 AM)blakeflorin Wrote:  Been screwing around for three days trying to figure this out. Finally see what its doing. I've gone through the latest three firmware versions for the T48G, all the same. Every other parameter I've used the $MAC wildcard in works correctly....except auto provisioning a VPN.

OpenVPN included in Freepbx drops each phones vpn file in the root of the tftp directory. Filename is formatted $MAC-vpn.tar. Manually uploading this file to the web interface works.

static.openvpn.url = tftp://##.###.##.7/$MAC-vpn.tar
^ the phone will download the file, even compares MD5 against the existing vpn file in its slot, but bombs out trying to start the connection.

I manually created a sub folder off the root using a mac address, renamed the file to remove the wildcard option.
static.openvpn.url = tftp://##.###.##.7/$MAC/open-vpn.tar
^ the phone downloads the file, compares and starts right up.

Also tried another variation-
static.openvpn.url = tftp://##.###.##.7/$MAC.tar
^ the phone downloads the file, compares and bombs out.

I would call this a bug between the file upload handler and starting the connection.

Maybe there's some option to make this work using " " or <MAC>, ??

Dear customer,
This is Paul from Yealink Technical Support Team, nice to meet you.
Thanks for your feedback, I will submit your feedback to our R&D guys.
Keep you updating.

BR
Paul


RE: autoprovision VPN - $MAC - blakeflorin - 06-08-2017 05:06 PM

Thanks for looking into this.

Blake