Yealink Forums
DHCP option 132, 3CX, and broadcasts - Printable Version

+- Yealink Forums (
+-- Forum: IP Phone Series (/forumdisplay.php?fid=4)
+--- Forum: General topics (/forumdisplay.php?fid=15)
+--- Thread: DHCP option 132, 3CX, and broadcasts (/showthread.php?tid=4006)

DHCP option 132, 3CX, and broadcasts - DennisT - 06-26-2015 05:47 AM

I'm evaluating 3CX and came across a problem. Here's what appears to be happening:
T19 (firmware: - tried also) boots and does a DHCP request.
The switch (Cisco 3850) routes the request to my main DHCP server.
Server responds to the request.
T19 sets its IP and then does a broadcast. 3CX sees the broadcast (phone appears in Server Manager -> Phones w/the assigned IP).
T19 sees that there is an option 132 and drops its IP and makes a new request on the VLAN specified in option 132 (10).
The switch routes the request to the VLAN 10 DHCP server (also the 3CX server).
The VLAN10 DHCP server responds.
The T19 set its IP to the one it was given by the server.

The attached file is a syslog (6) of what happened. I don't see that it is making any broadcasts once it gets the VLAN 10 IP. So I have a new record showing in Server Manager -> Phones for this phone, but with the wrong IP.

This isn't the behavior I expected. I expected to see the phone appearing with the correct IP, or next best twice, once for each IP.

I suppose I could work around this by using a static IP and manually assigning the VLAN info but I'd really like to avoid manually setting this on every phone. Anyone have any ideas on what I'm doing wrong?

RE: DHCP option 132, 3CX, and broadcasts - Elaine_Yealink - 06-26-2015 06:09 AM

Dear Dennis,

If DHCP VLAN is applied in your environment, please disable the LLDP as the screenshot attached.
The provision parameter for LLDP is:

network.lldp.enable =


RE: DHCP option 132, 3CX, and broadcasts - DennisT - 06-26-2015 06:41 AM

Thanks for the quick reply.

I had to bump the firmware back up to as the network/advanced settings page wouldn't display. Did a full factory reset and then set LLDP to disable. Rebooted and its the same thing. The T19 appears on the 3CX -> Server Manager -> Phones page with the default VLAN address and not the VLAN 10 address.