Yealink Forums
account settings ignored, other settings work - Printable Version

+- Yealink Forums (
+-- Forum: IP Phone Series (/forumdisplay.php?fid=4)
+--- Forum: Auto Provisioning (/forumdisplay.php?fid=14)
+--- Thread: account settings ignored, other settings work (/showthread.php?tid=39950)

account settings ignored, other settings work - mivk - 11-20-2016 12:55 PM

I'm trying to auto-provision T46G and T48G phones. They do get their macaddress.boot files from the TFTP server, and do correctly apply all settings, except the personal account settings, which seem to be completely ignored.

For example, a T48G is running firmware

macaddress.boot :

account.1.enable = 1
account.1.label = 431-John IP.161
account.1.display_name = 431 John
account.1.user_name = 431
account.1.auth_name = 431
account.1.password = Start

overwrite_mode = 1

# SIP server, time, language, +phonebooks?
include:config "yealink-all.cfg"

Only the settings from the included "yealink-all.cfg" are applied. The account settings above are not.

The settings which do work are stuff like:

account.1.sip_server.1.address = asterisk.frenetic.lan
account.1.sip_server.2.address =
local_time.time_zone = +1
local_time.time_zone_name = None
local_time.dhcp_time = 1
local_time.ntp_server1 = time.frenetic.lan
local_time.ntp_server2 =
local_time.interval = 7200
# etc.

What can I do to make sure the account settings are also applied?


RE: account settings ignored, other settings work - Karl_Yealink - 11-21-2016 10:05 AM


The boot file only can recognize cfg path and overwrite_mode strings.
You can create an new cfg file, and add the account configuration string in this file.
Then add a cfg path string in boot file.

Just like
include:config "account.cfg"

RE: account settings ignored, other settings work - mivk - 11-21-2016 06:46 PM

Thank you.

I have now tried to only have includes in the macaddress.boot file:


include:config "yealink-all.cfg"
include:config "linekey.cfg"
include:config "http://frenetic.lan/phones/yealink.php"
include:config "http://frenetic.lan/phones/test2.cgi"

overwrite = 1

The last included config (test2.cgi) prints the following with a content-type of "text/plain" :
account.1.enable = 1
account.1.password = Start
account.1.label = 430-Viktor
account.1.user_name = 430
account.1.auth_name = 430
account.1.display_name = Viktor

Still, all settings are applied, except the account settings.

I have also tried only including that account file and nothing else, but it made no difference.

Would anybody have a working configuration to share as an example?

RE: account settings ignored, other settings work - mivk - 11-23-2016 09:54 AM

When the phone is reset to factory defaults, it does apply the account settings. But if they have been modified through the web interface, they are not applied at the next reboot.

My current macaddress.boot file :

include:config "http://frenetic.lan/phones/account.cgi"
include:config "yealink-all.cfg"
overwrite_mode = 1

Is it possible to force the overwriting of all settings on boot, even those which have been manually modified? I thought that "overwrite_mode=1" would do just that, but apparently not.