Yealink Forums
T19 - auto provisioning problem - Printable Version

+- Yealink Forums (http://forum.yealink.com/forum)
+-- Forum: IP Phone Series (/forumdisplay.php?fid=4)
+--- Forum: Auto Provisioning (/forumdisplay.php?fid=14)
+--- Thread: T19 - auto provisioning problem (/showthread.php?tid=3817)



T19 - auto provisioning problem - lorn10 - 05-17-2015 09:17 PM

Hi there

Unfortunately I have a problem with auto provisioning on my Yealink T19P phones. The following parameters works great for Yealink T32G & T38G, but not for Yealink T19P. For example, the T19P phones do not apply any daylight data trough provision. It seems that only a little part of the provision file are applied.

According to the documentation I found, both phones use M7 template format. However, T19P has V72 firmware while T3xG has V70+ firmware.

What I am doing wrong? Could someone tell me furthermore the correct syntax for European daylight savings on T19P? It seems that it is not the same like on T3xG. Huh

Note: Daylight savings begins in Central Europe always at the last Sunday in March at 01:00 UTC (02:00 CET) until the last Sunday in October at 01:00 UTC (03:00 CEST).

I use FreePBX 5.211.65-21 and OSS End Point Manager 2.11.9.

Code:
#!version:1.0.0.1
## the file header "#!version:1.0.0.1" can not be edited or deleted. ##

#
local_time.dhcp_time = 0
local_time.time_zone = {$timezone}
local_time.time_zone_name = {$timezone_name}
local_time.manual_ntp_srv_prior = 0
local_time.ntp_server1 = {$network_time_server}
local_time.ntp_server2 = pool.ntp.org
local_time.interval = 21600
local_time.summer_time = 2
local_time.dst_time_type = 1
local_time.start_time = 3/5/7/1
local_time.end_time = 10/5/7/2
local_time.offset_time = 60
local_time.manual_time_enable = 1
local_time.time_format = 1
local_time.date_format = 5

.
.



RE: T19 - auto provisioning problem - James_Yealink - 05-19-2015 05:31 AM

Hello,

Can you use the follow parameter to do an autoprovision:

local_time.summer_time = 1
local_time.dst_time_type = 1
local_time.start_time = 3/5/7/1
local_time.end_time = 10/5/7/2
local_time.offset_time = 60
local_time.manual_time_enable = 0
local_time.time_format = 1
local_time.date_format = 5

Regards,
James


RE: T19 - auto provisioning problem - lorn10 - 05-19-2015 05:02 PM

(05-19-2015 05:31 AM)Yealink_James Wrote:  Hello,

Can you use the follow parameter to do an autoprovision:

local_time.summer_time = 1
local_time.dst_time_type = 1
local_time.start_time = 3/5/7/1
local_time.end_time = 10/5/7/2
local_time.offset_time = 60
local_time.manual_time_enable = 0
local_time.time_format = 1
local_time.date_format = 5

Regards,
James

Hi James

Thanks for your response. I tried your example. It also does not work for T19P. Question, is the sequence / order of the command mandatory?

My current sequence is:
Code:
local_time.dhcp_time = 0
local_time.time_zone = {$timezone}
local_time.time_zone_name = {$timezone_name}
local_time.manual_ntp_srv_prior = 0
local_time.ntp_server1 = {$network_time_server}
local_time.ntp_server2 = pool.ntp.org
local_time.interval = 21600
local_time.summer_time = 1
local_time.dst_time_type = 1
local_time.start_time = 3/5/7/1
local_time.end_time = 10/5/7/2
local_time.offset_time = 60
local_time.manual_time_enable = 1
local_time.time_format = 1
local_time.date_format = 5

Only different parameter is:
Code:
local_time.summer_time = 1


In my config I had:
Code:
local_time.summer_time = 2

None of these parameters are adopted.

On T32G & T38G range IP phone this config works perfect.


RE: T19 - auto provisioning problem - James_Yealink - 05-19-2015 09:34 PM

Please try setting this parameter to 0 and check again.

local_time.manual_time_enable = 0


RE: T19 - auto provisioning problem - lorn10 - 05-19-2015 10:58 PM

Thanks James for your fast answer. Unfortunately this also doesn't work. Very strange... Sad

The good thing is that I can use the phone for calls. After entering the password and username in the web-GUI, the phone starts to work. FreePBX is accepting it as all other Yealink phones.

As mentioned, no other information is overtaken. Just the username and password which I enter manually. (Also the new web-GUI password is ignored.)

Well, I think I found the problem. Could it be possible that my provision config files has wrong name? The syntax format is M7, but the config name is probably wrong. This is generated by OSS End Point Manager, - so far I know it is derived from the T18P line.

Update:
I can confirm that the $mac.cfg file provise correctly. The other y0000000000$suffix.cfg file is fully ignored. Reason; it has most likely wrong filename (same as the T18P).


RE: T19 - auto provisioning problem - James_Yealink - 05-19-2015 11:31 PM

So phone don't download the parameter in common file. The common file name for T19 is y000000000031.cfg. Can it work after you chaning it?


RE: T19 - auto provisioning problem - lorn10 - 05-20-2015 12:40 AM

Yes, the phone don't download the parameters because the generated common file has name of T18P.

Will check if I can change it. Well, there is no direct way to do that, - I had to export and edit the corresponding "Yealink Package" in OSS End Point Manager. This will be a new challenge. Wink

After this the provision should work.

Many thanks for your help James! Smile