Yealink Forums
T42G NTP time sync issues - Printable Version

+- Yealink Forums (
+-- Forum: IP Phone Series (/forumdisplay.php?fid=4)
+--- Forum: T4x Series (/forumdisplay.php?fid=31)
+--- Thread: T42G NTP time sync issues (/showthread.php?tid=3206)

T42G NTP time sync issues - kevinwalkerca - 01-28-2015 06:38 AM

I have three sets of T42G phones:

Set 1 (10 phones): Firmware version
Set 2 (2 phones): Firmware version
Set 3 (1 phone): Firmware version

All have the following time settings:
DHCP Time = Disabled
Primary Server =
Secondary Server =

The issue is that all the phones (except one in Set 2) show the same incorrect time. The time is slow by 3.5 minutes. The one phone in Set 2 is exactly the same as a radio sync'd clock I have.

I have set one of the incorrect time phones "Manual=Enabled", then changed the time to something completely wrong, then changed it back "Manual=Disabled" and the time jumps back to being off by 3.5 minutes.

I have tried different NTP servers and all have the same result. The one phone shows the correct time and all others are off by 3.5 minutes.

RE: T42G NTP time sync issues - James_Yealink - 01-28-2015 09:19 AM

Hi kevin,

Can you try facotry resetting one phone?
If the problem persist, can you get a pcap trace to check whether the time included in NTP packet is correct?


RE: T42G NTP time sync issues - kevinwalkerca - 01-28-2015 11:34 PM

The issue has been resolved. We have two domain controllers and one had an incorrect time. Even with the settings above it appears that some phones were getting their time from the DC with the bad time. Once the time on the DC was corrected the phones started displaying the correct time.