Yealink Forums
T48 stuck in boot - Printable Version

+- Yealink Forums (
+-- Forum: IP Phone Series (/forumdisplay.php?fid=4)
+--- Forum: Phone specific topic (/forumdisplay.php?fid=12)
+--- Thread: T48 stuck in boot (/showthread.php?tid=2727)

T48 stuck in boot - KristianMedK - 11-07-2014 04:49 PM

i installed firmware and now my phone i stuck at the welcome screen while booting (30 minutes now).

is there a way to do a factory reset when the phone cannot boot up ?

i tried setting up my own tftp server to make it download the old firmware again, but i get a file not found error for t48.bin and t48.rfs. which makes sense since those files aren't present, but i can't find information anywhere about what those files are supposed to contain ?

RE: T48 stuck in boot - KristianMedK - 11-07-2014 06:39 PM

managed to get the t48.rfs & t48.bin from a public tftp server.

would still like to know if there's an official library of some sort from yealink with the .revovery files for each phone.

RE: T48 stuck in boot - Yealink_Jim - 11-10-2014 08:47 AM

Please go to below link to get the t48.rfs & t48.bin files:

Hope this helps!

RE: T48 stuck in boot - rmeier - 08-13-2015 02:43 AM

i have the same problem on a brand-new T48 Phone. I've done a firmware update over auto provisioning and it hangs in the update process.
After an hour wait, i disconnect the Ethernet (POE).

Connect again and the phone is standing in the first boot screen.

i turn on my TFTP Server and try to upload the 3 Files. Jim, your links don't work. I found these Files somewhere on the Internet. Please make these files available on the Yealink Support Page. There is only the ROM File in the download Area.

now my point is, that the firmware upgrade process over TFTP also depends.
the T48 Phone loads the 2 Files up and start the upgrade process. Then it loads the ROM File an it freeze.

Could it be that the Firmware update doesn't work with POE? I've ordered a PowerSupply and will try the update tomorrow...


RE: T48 stuck in boot - rmeier - 08-13-2015 05:15 PM

Hello again

I tried the Recovery Mode with the new Poweradapter and the Files from here :
It doesn't work. The Firmware Process freeze at "Firmware updating... Please do not power off !" for an hour.

What i can try next?