Yealink Forums
T32G OpenVPN Config - Printable Version

+- Yealink Forums (
+-- Forum: IP Phone Series (/forumdisplay.php?fid=4)
+--- Forum: Configuration (/forumdisplay.php?fid=24)
+--- Thread: T32G OpenVPN Config (/showthread.php?tid=2717)

T32G OpenVPN Config - - 11-06-2014 06:13 AM

I am having issues configuring OpenVPN for the yealink T32G phone. This a brand new phone I purchased and it supports OpenVPN but I see no sign of OpenVPN running in the logs. The 4 files in my "openvpn.tar" are:


Please see the below vpn.cnf: (yes it matches my server.conf file and verified connection works via OpenVPN app from my phone)

remote X.X.X.X
ca /phone/config/openvpn/keys/ca.crt
cert /phone/config/openvpn/keys/client1.crt
key /phone/config/openvpn/keys/client1.key
port 1194
proto udp

I'm not finding any logs about VPN after I've uploaded the "openvpn.tar", enabled, and confirmed the settings.

Any assistance would be greatly appreciated. I've heard a lot of people having issues with VPN issues with my model. I've already submitted a request via

Thank you.

RE: T32G OpenVPN Config - cptjack - 11-06-2014 06:21 AM

Can you try renaming the private key and client certificate to "client.crt" and "client.key"?
I have successfully tested openvpn on the T38G and the codebase should be compatible with T32G.
Please rename the two files first as I believe the filenames are hardcoded and the phone needs them like that.

If that does not resolve the issue, we can compare some vpn.cnf settings...

RE: T32G OpenVPN Config - James_Yealink - 11-06-2014 08:07 PM


I attach a Openvpn.tar sample.
Can you do some change according to the sample.

1. Change the tsl-client to client
2. Change the path of certificate files


RE: T32G OpenVPN Config - - 11-07-2014 02:42 AM

Thank you both so much for the support!! I changed all of the above items and it works!

Changed: tsl-client ---> client
Changed: key and cert from client1.crt --->client.crt and client1.key --->client.key
Changed: path /phone/config/openvpn/keys ---> /config/openvpn/keys

I know for a fact that changing tsl-client to client was an issue.

It works! Thanks.