Yealink Forums
Auto Provisioning error - Printable Version

+- Yealink Forums (
+-- Forum: IP Phone Series (/forumdisplay.php?fid=4)
+--- Forum: Auto Provisioning (/forumdisplay.php?fid=14)
+--- Thread: Auto Provisioning error (/showthread.php?tid=2366)

Auto Provisioning error - AndyInNYC - 09-07-2014 04:23 AM

I am having difficulty getting my T46G to pick up files during auto provisioning.

I have created a y000000000028.cfg file which sets a few buttons and should upload wallpaper and a directory.

I have the .45 (newest) firmware loaded on the phone.

The phone is connecting via OpenVPN (which works correctly).

I am attempting to get the config via ftp or tftp.

The config file is picked up and read (the buttons get set), but the wallpaper and directory don't get picked up. I have also tried connecting using the public IP of the server.

The machine is a Rentpbx machine running vsftpd software. I can ftp from a Windows machine with either WinSCP or ftp from a Chrome/IE window.

If I set the T46G to use tftp:\\IP I get a message in the log saying the (RentPBX) machine isn't a tftp server

If I use ftp, the error logs tell me:

2014-09-05 00:00:02: (mod_dirlisting.c.228) pcre support is missing, please install libpcre and the headers
2014-09-06 19:57:56: (mod_fastcgi.c.3059) got proc: pid: 408 socket: unix:/tmp/fcgiServer-fcgi.socket-0 load: 1

## the file header "#!version:" can not be edited or deleted. ##

account.1.auth_name =
account.1.display_name =
account.1.dtmf.type = 1
account.1.enable = 1
account.1.label =
account.1.outbound_host =
account.1.outbound_port =
account.1.outbound_proxy_enable = 0
account.1.password =
account.1.shared_line = 0
account.1.sip_server.1.address = OpenVPN IP of server
account.1.sip_server.1.port = 5060
account.1.sip_server.2.address =
account.1.sip_server.2.port =
account.1.user_name =

auto_provision.pnp_enable = 1
auto_provision.repeat.enable = 1
auto_provision.server.password = bob
auto_provision.server.url = ftp://(either OpenVPN IP or Public IP)
auto_provision.server.username = ftpclient
auto_provision.weekly.begin_time = 00:00
auto_provision.weekly.dayofweek = 0123456
auto_provision.weekly.enable = 1
auto_provision.weekly.end_time = 00:15

directory_setting.url = ftp://(the correct IP)/RemotePhonebook.xml

lang.gui = English

linekey.1.label = KKit (C)
linekey.1.line = 1
linekey.1.type = 13
linekey.1.value = aphonenumber
linekey.2.label = MKit (C)
linekey.2.line = 1
linekey.2.type = 13
linekey.2.value = aphonenumber
linekey.3.label = Great (C)
linekey.3.line = 1
linekey.3.type = 13
linekey.3.value = aphonenumber
linekey.4.label = Boat (C)
linekey.4.line = 1
linekey.4.type = 13
linekey.4.value = aphonenumber
linekey.5.label = Super (C)
linekey.5.line = 1
linekey.5.type = 13
linekey.5.value = aphonenumber
linekey.6.label = Somebody Else (C)
linekey.6.line = 1
linekey.6.type = 13
linekey.6.value = aphonenumber
linekey.7.label = Eucador (C)
linekey.7.line = 1
linekey.7.type = 13
linekey.7.value = aphonenumber

local_time.date_format = 0
local_time.ntp_server1 =
local_time.summer_time = 2
local_time.time_format = 1
local_time.time_zone = -5
local_time.time_zone_name = United States-Eastern Time

phone_setting.backgrounds = Config:thewallpaper.jpg = Custom

wallpaper_upload.url = ftp://(the correct IP)/thewallpaper.jpg

In all cases, the IP used matches throughout - the error doesn't change.

The wallpaper is the correct pixel size and the phonebook was created using the Yealink Excel directory tool.

Since the .cfg file is brought to the phone, the server is 'serving', but there appears to be some error in communications between phone and server. The server has an ftp user created named (uniquely enough) 'ftpclient' with a password (substituted as) 'bob' (not the real password).

This server is at RentPBX, is running iptables with ports open (obviously since I can ftp from the same location and get in (partially) with the phone).

uname -a && cat /etc/*release returns:
Linux (mydomain) 2.6.32-431.5.1.el6.i686 #1 SMP Tue Feb 11 13:30:23 CST 2014 i686 i686 i386 GNU/Linux
Scientific Linux release 6.5 (Carbon)

I'm running pbxinaflash 'Green' if that matters.

Any thoughts?


RE: Auto Provisioning error - Wilson_Yealink - 09-10-2014 10:19 AM

Hi Andrew,

Do you mean the linekey setting had taken effect but other settings didn't work? If yes, I think the phone had uploaded the CFG file succesfully. the Wallpaper and directory upload failed, it is probaly that the sentences are wrong.

Please try below steps:
1. Upload your wallpaper and directory into your phone via web interface to ensure the wallpaper.jpg and directory file are correct.
For example, Upload the wallpaper: Access to web GUI->Settings->Preference->Upload Wallpaper(480*272). Try it and confirm your picture format is correct.
2. Confirm your directory file is local directory or remotephone book, if it is local directory, the autop sentence is directory_setting.url =. If it is remote phonebook, the sentence is =. It is possible the fail reason. Please check it.
3. If you ensure all sentence is correct but it still doesn't work, please try HTTP server to auto provision. I will attached the software, we always use this software internal. Please try it and tell me the resut. You can get it from below link:
hfs software

If after above steps but it still doesn't work, Could you please send your CFG file ,wallpaper.jpg, directory file and send them to me? I will test it in my side.

My email address: