Yealink Forums
T21 Auto Provisioning Fails - Printable Version

+- Yealink Forums (http://forum.yealink.com/forum)
+-- Forum: IP Phone Series (/forumdisplay.php?fid=4)
+--- Forum: Auto Provisioning (/forumdisplay.php?fid=14)
+--- Thread: T21 Auto Provisioning Fails (/showthread.php?tid=2083)



T21 Auto Provisioning Fails - baddah - 07-17-2014 04:55 PM

Hi,

We are trying to get our auto provisioning working on a batch of T21P's. We've generally used T20's and T28's in the past and have had no issues with auto provisioning. Worked everytime.

We cannot get the T21 to take its settings. I've tried setting the tftp server via DHCP and manually on the GUI, and clicking auto provisioning now. When the phone boots up, it says 'Update skipped' and no config is loaded.

Attached is a sample max.cfg file. The tftp and dhcp side is fine as it works with T20 phones.

I was planning on trying to upgrade the firmware, but i noticed the following. On your website the latest firmware is 34.72.0.20, but if i check the firmware on the phone's status page it says 34.72.0.21! how can that be? Is there something wrong with the firmware on the phone?

I have looked at the syslog of the phone (which is set on level 3) and i can see no indication of any auto provisioning bweing done.

Any suggestions on what i can try. I'd hate to configure the phones manually one by one.....


RE: T21 Auto Provisioning Fails - baddah - 07-21-2014 03:09 PM

Hi,

I have reverted to configuring the barch of phones manually. When doing this i stumbled across another issue with the T21. None of the advanced tabs works when using firefox (tested with version 30). Advanced tabs does work with chrome.

So, is there any suggestions why auto provisioning does not work on the T21's with the firmware as stated? I'll spend some more time trying to get it working, but if this fails i'll have to move to another phone. I am dissapointed with the T21's sofar. They're the first Yealink's thats been giving me issues.


RE: T21 Auto Provisioning Fails - Wilson_Yealink - 08-26-2014 04:11 PM

Hi baddah,
Sorry for the delay. I have tested your mac.cfg file with T21 in my side. It does work well.
I think that file is fine. About the firmware version confusion, the 34.72.0.21 is RPS version of T21. It just has RPS feature more than 34.72.0.20 version. Please try below steps:
1.So far, the latest version of T21 is 34.72.0.75, you can get it from here. >>34.72.0.75<<
2.Reset your phone to factory.
3.Confirm your TFTP server is ok, and enter the correct auto provision URL to the Server URL field.
You can test the URL whether is correct or not via enter it into the address of broswer. If it is correct, you can download it via browser.

If this issue still exist after above steps, In order to do more troubleshootings, please supply syslog level 6, config.bin and pcap and send to wilson@yealink.com.

How to Get the Correct Syslog, Config.bin and Trace

About None of the advanced tabs works when using firefox, it is strange, please clear the browser cache and try again.

any update, please let me know.