Yealink Forums
T46G - Voice VLAN - 3cx - HP 4500G switch - Printable Version

+- Yealink Forums (
+-- Forum: IP Phone Series (/forumdisplay.php?fid=4)
+--- Forum: General topics (/forumdisplay.php?fid=15)
+--- Thread: T46G - Voice VLAN - 3cx - HP 4500G switch (/showthread.php?tid=2073)

T46G - Voice VLAN - 3cx - HP 4500G switch - jholcombe - 07-16-2014 05:26 AM


I have installed 3CX and set up a voice VLAN. I'm setting up a test system to see how the Yealink phones and 3CX will work in our environment, and so I can learn more about 3CX and Yealink phones. I want the phones to operate VoIP tagged on a voice VLAN. I want the workstations connected through the phones to operate untagged (default). I have configured the ports on a HP (3COM) 4500G switch as follows:

interface GigabitEthernet1/0/21
port link-type hybrid
port hybrid vlan 122 tagged {this is the VOICE VLAN}
port hybrid vlan 1 untagged {default VLAN for computers}
poe enable

On the default VLAN, I configured the DHCP server with option 132 to pass VLAN 122 to the phones when they boot up.

I have also modified the phone template to set the phones to VLAN 122.

When a phone boots:
1. It will obtain an IP address on the default network.
2. It will see the DHCP option 132 and switch to VLAN 122.
3. It will obtain an IP address on the VLAN 122 network.
4. It will briefly (about 10 seconds) reply to pings using the VLAN 122 IP address.
5. It will then revert back to the IP address it received on the default network, but it will remain on VLAN 122.

The phone actually communicates with the server somehow like this (the 3CX server is on the same layer-2 network, so could there be some layer-2 communications between the phone and the 3CX server), however, the phone is not reachable by pings (unless you put a host on VLAN 122 with an IP address compatible with the phone's IP).

Firmware version is: (doesn't appear to be available yet on Yealink's site).

I downgraded one of the phones firmware to version Now the phone gets a good IP address on VLAN 122, but the phone does not reply to pings, and is completely unreachable on the network on the 4500G switch.

I moved the phone to an older 3Com Switch 4400PWR (which is connected to the same 4500G switch) with a port configured the same way (untagged 1, tagged 122), and the phone boots properly, gets the correct IP address, and replies to pings. Also a computer plugged in through the phone gets a correct address on VLAN 1.

Any ideas on how I can get these to work on the 4500G switch?



RE: T46G - Voice VLAN - 3cx - HP 4500G switch - jholcombe - 07-16-2014 06:30 AM

Update: I have found that if I configure the port speed of the 4500G switch, or change the duplex, the phone will start responding (using the older firmware on the default VLAN), but the phone still won't respond on the correct VLAN. I changed the speed and duplex in the phone to 100-full, and set the switch to 100-full, however The T46G still doesn't reply on boot. On the switch, if I change the port speed or duplex once the T46G has booted, it will start to respond.

Perhaps there's an auto-negotiation issue on the port speed or duplex with Yealink Gigabit phones and certain switches? It's strange that it will start responding once I manually configure the switch port with a hard-coded duplex and speed (regardless of the phones duplex and speed setting).

Upgrading the firmware on the T46G to seems to help with the port auto-negotiation issues. However, I still have the problem with the phone not wanting to work on vlan 122. Now the phone is just not joining vlan 122 at all. It's getting an IP on the default vlan and not ever switching to vlan 122. I've set the vlan both in the phone config and DHCP option.

RE: T46G - Voice VLAN - 3cx - HP 4500G switch - jholcombe - 07-16-2014 07:39 AM

Upgrading the firmware on the T46G to causes the phone to properly connect to VLAN 122 on the 4500G switch, but it doesn't keep a correct IP address once it has moved to vlan 122. Instead, it briefly (about 5 seconds) gets an IP address for VLAN 122, then it reverts back to the IP address it had on VLAN 1. However, if I connect the T46G with firmware to an older 3Com 4400PWR, then it connects properly to VLAN 122 and gets (and keeps) the correct IP address for VLAN 122.

RE: T46G - Voice VLAN - 3cx - HP 4500G switch - jholcombe - 07-22-2014 01:08 PM

Unfortunately we are required to separate our VoIP traffic from our data traffic using VLANs because of CJIS regulations.

line # 441.

If there's any way to get this to work, it would be very much appreciated.

Thank you,


RE: T46G - Voice VLAN - 3cx - HP 4500G switch - jholcombe - 08-14-2014 09:13 AM

In case anyone else has this issue, Yealink tech support had me disable LLDP on the phone. Once that was done, everything worked as it was supposed to. Phone connects 1 Gigabit, connects to the correct VLAN, passes the untagged VLAN to the other switch port, and gets the correct IP address for the VOIP VLAN. Thanks!

RE: T46G - Voice VLAN - 3cx - HP 4500G switch - Yealink Support - 08-16-2014 11:42 AM

Thanks for your share.