Yealink Forums
T46G - wallpaper bug ? - Printable Version

+- Yealink Forums (
+-- Forum: IP Phone Series (/forumdisplay.php?fid=4)
+--- Forum: Phone specific topic (/forumdisplay.php?fid=12)
+--- Thread: T46G - wallpaper bug ? (/showthread.php?tid=1928)

Pages: 1 2

T46G - wallpaper bug ? - timalex - 06-20-2014 08:05 PM

Starting with Firmware, no problems to upload additional backgrounds to the phone.

After update to this stopped working, getting "500 - Internal Server Error". Tried different computers/browsers and reset to factory default.
New phones coming with preloaded, same problem.

Downgrade to and it's working again.

Guess this is a 28.72.x.x bug?
Any timeline to fix this?


RE: T46G - wallpaper bug ? - Yealink Support - 06-23-2014 05:28 PM

Hi timalex,

We have tested the wallpaper with the and firmware. It does work well.

The wallpaper image format must meet the following:

[Image: attachment.php?aid=795]

RE: T46G - wallpaper bug ? - timalex - 06-23-2014 06:30 PM

Funny enough, I can agree 50%. What I can tell you for sure is that it's not working with some phones straight out of the box.

And others do have the same kind of problems, please look at T48G - firmware bug - Background cannot be uploaded .

It's nothing about our file format. We use .jpg, exactly 480x272, size about 12kb. And, as User jayw654 in the other thread, we tried out all 3 file formats, tried out with IE and Firefox as browser, tried out with Win7 and WinXP, with or without reset to factory defaults also does not matter. Upload just not working, 500 internal server error, or just the phones login dialog again.

But, as soon as we downgrade a phone to 28.71.x.x, we can upload a picture without flaw.

Now the strange one: Going up to again and ... it still works. Saying, a temporarily firmware downgrade solves the problem.

So we would ask you to give this another try with fresh phones out of the box. Thx.

RE: T46G - wallpaper bug ? - Yealink Support - 06-24-2014 03:11 PM

Hi timalex,

Sorry for the inconvenience. Can you send your picture to me? I want to test in my side.


RE: T46G - wallpaper bug ? - timalex - 06-25-2014 03:56 PM

Will send you an email.

RE: T46G - wallpaper bug ? - Yealink Support - 06-25-2014 04:40 PM

My email address is


RE: T46G - wallpaper bug ? - Yealink Support - 06-25-2014 08:34 PM

Hi timalex,

Thanks for your mail.
I have tested the wallpaper which you sent me, it does work well.
So I made a short video about how to upload it for you.
You can get it from here.>>here<<

Please try follow steps:
1.Clear the buffer of the browser and try again.
2.Please upgrade the firmware to Download the firmware which I attached.

If it also doesn't work, please let me know how many phones have this issue.
Where and who did you buy the phone from?
Sorry for the inconvenience.


RE: T46G - wallpaper bug ? - timalex - 06-30-2014 07:26 PM

Hi Support,

was waiting with my reply until I was able to test another new phone. Same problem: "500 - Internal Server Error". Straight out of the box the wallpaper upload to the phone is not working.

Firmware; Hardware; Product ID 201403251109. German distribution channel (Allnet).

Also, please be so kind and read my above posts again. We already tried 3 different firmware versions inclusive the recommended We tried different machines, operating systems (XP/7) and browsers (ie/firefox, also with cache cleared). We tried several different phones out of 3 different shipments, all phones with language set to default English. First ones coming with, other coming with

With the last phone coming with .26 we now tried a downgrade first to only. This fixed the problem also! As said, the first phone was delivered with a 28.71. firmware and we know for sure that the upload was working with this version. But stopped working after firmware upgrade to! Same version that fixed the problem at downgrade time with the last phone... Strange, but just what we found today. Seems after you touch the initial firmware with a downgrade, it starts to be possible to upload the wallpapers without a problem. Unfortunately, neither we're able to repeat this test with a phone starting at 28.71 out of the box, nor we saw the problem ever again after a single firmware downgrade. Our current vague guess is, that an initial apply of firmware of (or upgrade to) major version 28.72.x.x sets some wrong file permissions, which are fixed by whatever downgrade is applied later. But just a guess to explain the above.

At next step I would recommend that you give it a try yourself again with a new phone out of the box coming with 28.72.x.x. Hopefully you then will be see the problem yourself. Thx.

RE: T46G - wallpaper bug ? - Yealink Support - 07-01-2014 02:56 PM

Hi timalex,

I have sent you private message. Please check it.


RE: T46G - wallpaper bug ? - Yealink Support - 07-04-2014 08:45 PM

Hi all,

Our R&D have released one new firmware which fixed this issue. Please download it and test it.
It is kindly you can feedback me in this thread.
You can get this firmware from here.>> <<

Thanks in advance