Yealink Forums
Call history not showing the right information after an attended transfer - Printable Version

+- Yealink Forums (http://forum.yealink.com/forum)
+-- Forum: IP Phone Series (/forumdisplay.php?fid=4)
+--- Forum: General topics (/forumdisplay.php?fid=15)
+--- Thread: Call history not showing the right information after an attended transfer (/showthread.php?tid=15337)



Call history not showing the right information after an attended transfer - wirelessmundi - 05-20-2016 05:07 PM

I've the following scenario:

10 ----> 11 - initial call
11 ---> 12 - put on hold 10, calls to 12 - in the display of 12 it shows talking with 11, and then 11 transfer 10 to 12.
10 ---> 12 - 10 and 12 talk, in the display of 12 it shows talking with 10

When the call ends, in the history of 12 it shows the call came from 11, and not from 10.

Is there a way/configuration that in the history to show that the call came from 10 instead of 11?


In the message log i see the message:

May 19 16:16:15 SIP [470]: SUA <5+notice> [000] remote party id updated to 10
...

May 19 16:16:18 Log [435]: TALK<6+info > 578.573.540:SaveCallLog OriginalSIPName = 11, RemoteSIPName = 10, OriginalDisplayName = 11, RemoteDisplayName = 10


the idea would be to show the RemoteSIPName = 10.


RE: Call history not showing the right information after an attended transfer - Yealink_Michael - 05-25-2016 09:31 PM

hi

may i know that which model and firmware you are using ?

please try below auto provision parameter to see if it helps or not :

features.pickup_caller_num_record.enable = 1

for how to do auto provision , please refer to the guide below :

http://support.yealink.com/attachmentDownload/download?path=upload%2Fattachment%2F2015-7-13%2F3%2Feb7b2fbc-3877-42e8-be19-c605e552aea1%2FYealink_SIP-T2_Series_T19%28P%29+E2_T4_Series_IP_Phones_Administrator_Guide_V80_60.pdf

TKS & BR

Michael


RE: Call history not showing the right information after an attended transfer - Chris Barron - 10-31-2017 05:03 PM

Hi all - I think i have a repeat of the above problem. The calling number i external but the call that's logged onto the c party phone is that of the transferred party. I am using 82.0.20 firmware and the problem seems the same on t41/46/48.

My config is as follows:

************Call History & Dialling*******************
features.call_completion_enable = 0
features.call_log_show_num = 1
features.call_out_history_by_off_hook.enable = 1
features.caller_name_type_on_dialing = 2
features.history_save_display = 1
features.save_call_history = 1
features.save_init_num_to_history.enable = 1
features.save_original_num.enable =1
phone_setting.call_info_display_method =0
phone_setting.called_party_info_display.enable =1
phone_setting.contact_photo_display.enable = 0
phone_setting.incoming_call.horizontal_roll_interval = 30
phone_setting.inter_digit_time = 6
phone_setting.predial_autodial = 0
transfer.save_initia_calllog.enable=1


RE: Call history not showing the right information after an attended transfer - dgibby - 07-26-2023 04:49 AM

We have this same exact problem (it was very well described) on a Yealink SIP-T46U. I don't know where to set the value mentioned as a potential solution (features.pickup_caller_num_record.enable). Is there a way to do this from the phone's web interface as an admin? Are we sure that was the solution? There was no update to the thread.

(05-20-2016 05:07 PM)wirelessmundi Wrote:  I've the following scenario:

10 ----> 11 - initial call
11 ---> 12 - put on hold 10, calls to 12 - in the display of 12 it shows talking with 11, and then 11 transfer 10 to 12.
10 ---> 12 - 10 and 12 talk, in the display of 12 it shows talking with 10

When the call ends, in the history of 12 it shows the call came from 11, and not from 10.

Is there a way/configuration that in the history to show that the call came from 10 instead of 11?


In the message log i see the message:

May 19 16:16:15 SIP [470]: SUA <5+notice> [000] remote party id updated to 10
...

May 19 16:16:18 Log [435]: TALK<6+info > 578.573.540:SaveCallLog OriginalSIPName = 11, RemoteSIPName = 10, OriginalDisplayName = 11, RemoteDisplayName = 10


the idea would be to show the RemoteSIPName = 10.



RE: Call history not showing the right information after an attended transfer - Aragorn - 08-13-2023 06:15 PM

Has anybody found how shoul that be resolved? I've got the the same issue. I can't find a solution anywhere.


RE: Call history not showing the right information after an attended transfer - Yisroel_MongoTEL - 08-15-2023 12:41 AM

(07-26-2023 04:49 AM)dgibby Wrote:  We have this same exact problem (it was very well described) on a Yealink SIP-T46U. I don't know where to set the value mentioned as a potential solution (features.pickup_caller_num_record.enable). Is there a way to do this from the phone's web interface as an admin? Are we sure that was the solution? There was no update to the thread.

I do not know if this was a solution. But if you want to try setting this parameter you need to add it to a provisioning file (which it doesn't seem like you have) or import a config file with it.

Simply save a .cfg file (or download the attached) with the following in it:
Code:
#!version:1.0.0.1

features.pickup_caller_num_record.enable = 1

And import it to the Web GUI (under Settings > Configuration.)