Yealink Forums
Autoprovision on HTTPS - Printable Version

+- Yealink Forums (http://forum.yealink.com/forum)
+-- Forum: IP Phone Series (/forumdisplay.php?fid=4)
+--- Forum: T4x Series (/forumdisplay.php?fid=31)
+--- Thread: Autoprovision on HTTPS (/showthread.php?tid=13722)



Autoprovision on HTTPS - PCVALaw - 04-06-2016 01:41 AM

Yealink T48G
Firmware 35.73.0.50 (Vonage doesn't support v80 yet)
Autoprovision question.

I've struggled to get autoprovisioning to work such that it saves the <MAC>-local.cfg file to my web server using a PUT command. I'm using IIS 7.5 on Windows Server 2008 R2. I've finally got it working well, but I need a little more.

I had to enable WebDAV. WebDAV on IIS7 and above requires authentication. No anonymous uploads.

I've got it working now with the following line in my y000000000035.cfg file:
Code:
auto_provision.server.url = http://PhonesAccount:c0mpl3xP@$$w0rd@yealink.myurl.com/

If I change it to https (so the password isn't sent in plain text, probably across the internet when people take their phones home), it stops working.

I can only get it to autoprovision on IIS 7.5 and have it save its <MAC>-local.cfg on HTTP.

The SSL cert is a GoDaddy wildcard certificate that is respected on the web.

Anyone have any ideas?


RE: Autoprovision on HTTPS - Karl_Yealink - 04-06-2016 08:46 PM

For the Vonage problem, please contact with Vonage for help.


RE: Autoprovision on HTTPS - PCVALaw - 04-13-2016 04:14 AM

(04-06-2016 08:46 PM)Yealink_Karl Wrote:  For the Vonage problem, please contact with Vonage for help.

This is not a Vonage problem.

How can I make HTTPS work while providing a password?


RE: Autoprovision on HTTPS - Karl_Yealink - 04-30-2016 10:38 PM

Note that the V73 can't support SHA256, only the V80 support. Please check whether your certificate use the SHA256.