Yealink Forums
T42G Will not update firmware - Printable Version

+- Yealink Forums (
+-- Forum: IP Phone Series (/forumdisplay.php?fid=4)
+--- Forum: Phone specific topic (/forumdisplay.php?fid=12)
+--- Thread: T42G Will not update firmware (/showthread.php?tid=12442)

T42G Will not update firmware - itdweeb99 - 02-10-2016 06:00 AM

We have an office of about 15 T42G phones. All of these phones are running firmware I'm having a weird issue with action URLs getting truncated. Yealink recommended that I updated to the latest version of firmware. I downloaded the latest version and attempted to apply it to 3 different phones. None of the phones seem to take the new firmware. The phone acts as though the upgrade goes through properly but when I check the firmware, it still shows the old version. Yealink is closed for 2 weeks or something ridiculous so I can't get a response from them. Any ideas as to why the firmware won't take? I've tried several different versions including and Both had the same result on all three phones that I tried.

RE: T42G Will not update firmware - itdweeb99 - 02-11-2016 02:39 AM

There is a brand new version of firmware on yealinks site for the T42G. I downloaded it and applied it to one of our phone and I am actually seeing what is happening. I think it is applying the new firmware and then rolling back to the old version because for just a few seconds, I saw that the phone was reporting the new firmware version in our 3cx console. However, 30 seconds later, I notice that the phone is offline. Once the phone comes back online, I see it showing the old firmware version in the 3cx console and on the phone interface.