Yealink Forums
Battery life very poor - Printable Version

+- Yealink Forums (http://forum.yealink.com/forum)
+-- Forum: Dect Phone Series (/forumdisplay.php?fid=6)
+--- Forum: W52P (Wireless) (/forumdisplay.php?fid=23)
+--- Thread: Battery life very poor (/showthread.php?tid=1244)



Battery life very poor - Charliestott - 02-14-2014 10:19 PM

I have 4 W52P phones all on their own base stations, they all have the latest firmware as do the base stations

2. 26.40.0.15 ( Handset Firmware )
3. 25.40.0.15 (Base)
And all of them suffer from appalling battery life, less than half a day at best.
I have tried new batteries and charged them over night but as soon as i us them the next day they die very quick.

Any Ideas, or any fixes would be greatly appreciated?


RE: Battery life very poor - Yealink Support - 02-17-2014 10:43 AM

Hi Charliestot,

I am sorry about this issue. I want to share some tips with you.
1. The battery will be red and flash after upgraded. So i advise you to charge them fullly after upgraded.
2. The battery need to be charged fullly about 5~6 hours.

If you do follow my tips and the issue happens again, please describe the steps for me and supply syslog level 6, config.bin and pcap to me.
1. Before you export the syslog, please set syslog level as 6, and reboot the phone
2. then enter the webpage, find the pcap feature, click Start ,and reproduce the issue, then click Stop, and export the pcap, syslog, config.bin to us.
(About where to export these files, please refer to attached screenshots.)

These three files are very important to us, hope you can kindly understand.


RE: Battery life very poor - ike - 02-27-2014 11:20 PM

Hi Yealink Support,
i have the same problem (newest firmware also).
You wrote "10 hours talk time, 100 hours standby time" in your product sheet.
What battery do you use?
What minimal hours are ok and not guarantee? (e.g. 9 hours talk, 90 hours standby time is ok? or 8 hours/80 hours or....?)

Btw.:
You wrote:
"then enter the webpage, find the pcap feature, click Start ,and reproduce the issue, then click Stop, and export the pcap, syslog, config.bin to us."
What should i do?:
1. press Start
2. reproduce the issue - Battery run's low
3. press Stop (after Minutes / Hours)?!

Thank you


RE: Battery life very poor - Yealink Support - 02-28-2014 12:21 PM

Hi all,

Please make sure that you use the battery of same brand.
Can you describe more details for me? How many times of calls that you use these handsets?


RE: Battery life very poor - Charliestott - 02-28-2014 05:08 PM

I reloaded the old firmware ( 26.30.0.40 ) and the battery life was back to normal, so i think i will just leave it at that for now as i dont have any more time to test as the phones are being used for business. and it is difficult to take them off line for testing......


RE: Battery life very poor - Yealink Support - 03-01-2014 11:35 AM

Hi all,

We will help to find this reason. Our resellers remind that we added some protections in version 25.40.0.15 to prevent charging overheating.
So battery which is new or put for a long time needs activation process:

Low battery tips - > in charge with a normal use.

So after repeated three times to ensure the maximum performance of battery

Can you have a try and give a feedback to me?


RE: Battery life very poor - marcb@summitokc.com - 02-26-2016 09:33 PM

I see this thread is from 2014.
I currently have handsets with real poor battery life.
they are dead by noon. have to switch out batteries to get through the rest of the day.
units were bought new back in October 2015.

firmware on my units are 26.73.0.11 on the handset and 25.73.0.40 on the base.

went to try to download the 26.30.0.50 firmware as suggested in the thread but ftp wants a user name and password.
yealink website doesn't have this version


Has there been a fix for this?


RE: Battery life very poor - tritch - 11-15-2016 10:12 PM

marcb, I'm curious... did you ever get this resolved?

I recently purchased 2 handsets that hold the charge just fine, but 1 handset that does not.

On this 1 bad handset, I've tried the following:

1) flashed the firmware down to 26.40.0.15 back to 26.73.0.30
2) replaced batteries twice
3) completely discharged/recharged battery several times
4) tried different charging cradles

I've noticed the charging cycle algorithm is different between the good handsets that hold the charge and the one that does not after being fully charged:

2 good handsets: 2 minutes on / 2 ½ minutes off (holds charge)
1 bad handset: 2 minutes on / 5 seconds off (does not hold charge)

Nothing seems to fix this 1 handset, nor does anything change the charging cycle algorithm to the same as the good handsets.

Also noticed that the hardware versions of the good handsets are different from the bad one:

Good handsets: 26.0.0.10
Bad handset: 26.0.0.7

The batteries constantly feel warm on the bad handset even after it shows fully charged, so obviously the batteries are being overcharged.

I've come to the conclusion that either the charging circuit is bad on this 1 handset, or handsets with hardware version 26.0.0.7 have a defective charging design.