Yealink Forums
Cannot upgrade T41 firmware from 36.73.0.50.rom to 36.80.0.70.rom via autop - Printable Version

+- Yealink Forums (http://forum.yealink.com/forum)
+-- Forum: IP Phone Series (/forumdisplay.php?fid=4)
+--- Forum: Auto Provisioning (/forumdisplay.php?fid=14)
+--- Thread: Cannot upgrade T41 firmware from 36.73.0.50.rom to 36.80.0.70.rom via autop (/showthread.php?tid=11683)



Cannot upgrade T41 firmware from 36.73.0.50.rom to 36.80.0.70.rom via autop - jcaruso - 12-09-2015 12:18 AM

I am trying to upgrade some T41s from 36.73.0.50.rom to 36.80.0.70.rom
We use the same server for provisioning other models of phones (T26) and have not had trouble with it except on the T41.


I have a syslog.tar with level 6 debugging from the phone available if I can send it in somewhere. Here is a scrubbed version showing where it fails to download the firmware file:

Dec 8 14:22:11 FWUP[329]: ANY <0+emerg > 531.952.195:FWUP log :type=1,time=1,E=3,W=4,N=5,I=6,D=7
Dec 8 14:22:11 FWUP[329]: ANY <0+emerg > 531.952.478:ANY =6
Dec 8 14:22:11 FWUP[329]: ANY <0+emerg > 531.952.528:libfwup build:1.0.5.1-release(Nov 12 2014,03:58:32).
Dec 8 14:22:12 FWUP[329]: FWE <5+notice> 532.179.944:firmware logging :2015-12-8,14:22:12,179.807
Dec 8 14:22:12 FWUP[329]: FWE <5+notice> 532.180.628:firmware build-at:Nov 12 2014,03:58:25
Dec 8 14:22:12 LIBD[329]: DCMN<6+info > Enter Func dl_open....
Dec 8 14:22:12 LIBD[329]: DCMN<6+info > Enter Func dl_url_parse....
Dec 8 14:22:12 LIBD[329]: DCMN<6+info > Skip Space Success!
Dec 8 14:22:12 LIBD[329]: TFTP<5+notice> tftp open begin, host: mypbx.address, port:69, remote_name:/36.80.0.70.rom
Dec 8 14:22:12 LIBD[329]: TFTP<6+info > Send Request Packet
Dec 8 14:22:17 FWUP[329]: FWE <3+error > 537.185.062:failed to open,Success
Dec 8 14:22:17 LIBD[329]: DCMN<6+info > Enter Func dl_close....
Dec 8 14:22:17 LIBD[329]: DCMN<3+error > Invalid Param!
Dec 8 14:22:17 FWUP[329]: DEV <3+error > 537.189.407:fireware create failed,Success
Dec 8 14:22:17 FWUP[329]: UPD <3+error > 537.190.034:fireware init failed
Dec 8 14:22:17 ATP [329]: ATP <3+error > fwup_create Err
Dec 8 14:22:18 netS[297]: LLDP<6+info > unknown policy field received,or not from switch
Dec 8 14:22:20 FWUP[329]: ANY <0+emerg > 540.192.277:FWUP log :type=1,time=1,E=3,W=4,N=5,I=6,D=7
Dec 8 14:22:20 FWUP[329]: ANY <0+emerg > 540.192.963:ANY =6
Dec 8 14:22:20 FWUP[329]: ANY <0+emerg > 540.193.940:libfwup build:1.0.5.1-release(Nov 12 2014,03:58:32).
Dec 8 14:22:20 FWUP[329]: DEV <4+warnin> 540.194.854:device already identify
Dec 8 14:22:20 FWUP[329]: FWE <5+notice> 540.196.222:firmware logging :2015-12-8,14:22:20,196.153
Dec 8 14:22:20 FWUP[329]: FWE <5+notice> 540.207.788:firmware build-at:Nov 12 2014,03:58:25
Dec 8 14:22:20 LIBD[329]: DCMN<6+info > Enter Func dl_open....
Dec 8 14:22:20 LIBD[329]: DCMN<6+info > Enter Func dl_url_parse....
Dec 8 14:22:20 LIBD[329]: DCMN<6+info > Skip Space Success!
Dec 8 14:22:20 LIBD[329]: TFTP<5+notice> tftp open begin, host: mypbx.address, port:69, remote_name:/36.80.0.70.rom
Dec 8 14:22:20 LIBD[329]: TFTP<6+info > Send Request Packet
Dec 8 14:22:25 FWUP[329]: FWE <3+error > 545.204.998:failed to open,Success
Dec 8 14:22:25 LIBD[329]: DCMN<6+info > Enter Func dl_close....
Dec 8 14:22:25 LIBD[329]: DCMN<3+error > Invalid Param!
Dec 8 14:22:25 FWUP[329]: DEV <3+error > 545.208.806:fireware create failed,Success
Dec 8 14:22:25 FWUP[329]: UPD <3+error > 545.208.958:fireware init failed
Dec 8 14:22:25 ATP [329]: ATP <3+error > fwup_create Err
Dec 8 14:22:27 netS[297]: LLDP<6+info > unknown policy field received,or not from switch
Dec 8 14:22:28 FWUP[329]: ANY <0+emerg > 548.209.815:FWUP log :type=1,time=1,E=3,W=4,N=5,I=6,D=7
Dec 8 14:22:28 FWUP[329]: ANY <0+emerg > 548.211.037:ANY =6
Dec 8 14:22:28 FWUP[329]: ANY <0+emerg > 548.211.151:libfwup build:1.0.5.1-release(Nov 12 2014,03:58:32).
Dec 8 14:22:28 FWUP[329]: DEV <4+warnin> 548.211.222:device already identify
Dec 8 14:22:28 FWUP[329]: FWE <5+notice> 548.211.745:firmware logging :2015-12-8,14:22:28,211.682
Dec 8 14:22:28 FWUP[329]: FWE <5+notice> 548.211.848:firmware build-at:Nov 12 2014,03:58:25
Dec 8 14:22:28 LIBD[329]: DCMN<6+info > Enter Func dl_open....
Dec 8 14:22:28 LIBD[329]: DCMN<6+info > Enter Func dl_url_parse....
Dec 8 14:22:28 LIBD[329]: DCMN<6+info > Skip Space Success!
Dec 8 14:22:28 LIBD[329]: TFTP<5+notice> tftp open begin, host: mypbx.address, port:69, remote_name:/36.80.0.70.rom
Dec 8 14:22:28 LIBD[329]: TFTP<6+info > Send Request Packet
Dec 8 14:22:33 FWUP[329]: FWE <3+error > 553.214.973:failed to open,Success
Dec 8 14:22:33 LIBD[329]: DCMN<6+info > Enter Func dl_close....
Dec 8 14:22:33 LIBD[329]: DCMN<3+error > Invalid Param!
Dec 8 14:22:33 FWUP[329]: DEV <3+error > 553.219.494:fireware create failed,Success
Dec 8 14:22:33 FWUP[329]: UPD <3+error > 553.219.644:fireware init failed
Dec 8 14:22:33 ATP [329]: ATP <3+error > fwup_create Err
Dec 8 14:22:33 netS[297]: LLDP<6+info > unknown policy field received,or not from switch
Dec 8 14:22:36 ATP [329]: ATP <3+error > AUTOP: Upgrade rom from url fail!
Dec 8 14:22:36 ATP [329]: ATP <6+info > send end provision!!
Dec 8 14:22:36 Log [460]: ZERO<6+info >556.252.524:redirect done Result = 1, reboot = 0
Dec 8 14:22:36 ATP [329]: ATP <6+info > Update success, and return
Dec 8 14:22:36 ATP [329]: ATP <6+info > Upgrade by static config success !
Dec 8 14:22:36 ATP [329]: ATP <6+info > Poweron by default order success
Dec 8 14:22:37 netS[297]: LLDP<6+info > unknown policy field received,or not from switch
Dec 8 14:22:42 netS[297]: LLDP<6+info > unknown policy field received,or not from switch
Dec 8 14:22:44 netS[297]: LLDP<6+info > unknown policy field received,or not from switch
Dec 8 14:22:55 netS[297]: LLDP<6+info > unknown policy field received,or not from switch
Dec 8 14:22:55 netS[297]: LLDP<6+info > unable to guess frame type, dest mac [01 00 0c cc cc cc]
Dec 8 14:22:59 netS[297]: LLDP<6+info > unknown policy field received,or not from switch


RE: Cannot upgrade T41 firmware from 36.73.0.50.rom to 36.80.0.70.rom via autop - Karl_Yealink - 12-09-2015 12:26 AM

Hi,

Would you please send us the syslog and autop file, so we can check something from them.


RE: Cannot upgrade T41 firmware from 36.73.0.50.rom to 36.80.0.70.rom via autop - jcaruso - 12-09-2015 12:45 AM

Yes, where should I send them? support@yealink.com?

EDIT: I sent them to support@yealink.com, just let me know if they need to be sent elsewhere.
I sent the syslog.tar that exports from the Settings > Configuration page under Export System Log. It's set at System Log Level 6.
Where is the autop log? Only the following files are in syslog.tar:
$MAC.log
$MAC.log.0
lighttpd_error.log
web.log

Alright, after some additional troubleshooting we figured out the issue was on our local end.

It was due to a new firewall rule on our router that was rerouting traffic on UDP 69 to a different host.


RE: Cannot upgrade T41 firmware from 36.73.0.50.rom to 36.80.0.70.rom via autop - Karl_Yealink - 12-09-2015 05:10 AM

Hi,

You can send the email to me.