Yealink Forums
Ringback not possible due to SIP server in 'telephone number'? - Printable Version

+- Yealink Forums (http://forum.yealink.com/forum)
+-- Forum: IP Phone Series (/forumdisplay.php?fid=4)
+--- Forum: T4x Series (/forumdisplay.php?fid=31)
+--- Thread: Ringback not possible due to SIP server in 'telephone number'? (/showthread.php?tid=11228)



Ringback not possible due to SIP server in 'telephone number'? - chmars - 11-03-2015 03:52 PM

I have the following issues with all our Yealink SIP clients:

If a call is received, the Caller ID is shown as expected, for example 1234567890.

If I go to the call history to make a ringback, however, the clients do not use 1234567890 but 1234567890@SIPserver. SIPServer can be the IP address of the SIP server in use, a host name is possible too. And calling 1234567890@SIPserver does not work since the system obviously expects a telephone number.

Is there some option in the configuration to change this behavior of Yealink SIP clients?


RE: Ringback not possible due to SIP server in 'telephone number'? - James_Yealink - 11-03-2015 04:08 PM

Hello,

What's your phone model and firmware. Please upgrade phone to latest firmware and configure this option through provision:

features.redial_via_local_sip_server.enable = 1

Regards,
James


RE: Ringback not possible due to SIP server in 'telephone number'? - chris_flexfone - 11-03-2015 08:40 PM

I have the same problem - however the problem started with firmware 35.80.0.60 on T48G - i didn't see the issue before.

I have also tested 35.80.0.70 - but same problem.

I have tried "user=phone" in From header. I have also tried changing the cis_source to 5 and sending the number as RPID header. Same problem.

The phone keeps dialing number@domain from the SIPS URI when dialing back from history on an incomming or missed call...

This is a big issue for us, as all new T48G comes with the new version firmware - and whats worse, they cannot be downgraded!

This has caused us to remove the T48G temporarily from our order form...

UPDATE! I just tried features.redial_via_local_sip_server.enable = 1 and it works - the problem is solved - thanks.

How ever, this should be default behavior, and not something that must be changed for dialback to work (at least it has never been necessary before...)


RE: Ringback not possible due to SIP server in 'telephone number'? - chmars - 11-10-2015 01:52 AM

(11-03-2015 04:08 PM)Yealink_James Wrote:  What's your phone model and firmware. Please upgrade phone to latest firmware and configure this option through provision:

features.redial_via_local_sip_server.enable = 1

T42G with the latest firmware.

Is the option also available via the GUI?

Thanks anyway, issue resolved! Smile


RE: Ringback not possible due to SIP server in 'telephone number'? - James_Yealink - 11-10-2015 06:16 AM

Hello,

The option is not available in GUI now.
I will check why the behavior has been changed in new version with R&D.

Regards,


RE: Ringback not possible due to SIP server in 'telephone number'? - chmars - 03-02-2016 03:04 AM

@James: Is there any chance that the feature will make it into the configuration GUI?


RE: Ringback not possible due to SIP server in 'telephone number'? - baukevda - 03-11-2016 06:38 PM

http://forum.yealink.com/forum/archive/index.php?thread-11228.html


RE: Ringback not possible due to SIP server in 'telephone number'? - PacketLoss - 03-18-2016 05:53 AM

I am experiencing this exact same issue, I can not return calls from history because the @sipserver being appended to the end of the number, but when I actually look at the history the number appears without the sip server address. I am using the T46G Firmware 28.80.0.70

*** Update *** Found an updated firmware, will see if that gives me the magical option I have been missing.

Thanks


RE: Ringback not possible due to SIP server in 'telephone number'? - Davedog - 03-23-2016 04:11 AM

(11-03-2015 03:52 PM)chmars Wrote:  I have the following issues with all our Yealink SIP clients:

If a call is received, the Caller ID is shown as expected, for example 1234567890.

If I go to the call history to make a ringback, however, the clients do not use 1234567890 but 1234567890@SIPserver. SIPServer can be the IP address of the SIP server in use, a host name is possible too. And calling 1234567890@SIPserver does not work since the system obviously expects a telephone number.

Is there some option in the configuration to change this behavior of Yealink SIP clients?

Yes, redial via local sip server. I cannot believe this isn't set to default.

custom.features.redial_via_local_sip_server.enable = 1