Yealink Forums
Dial-Now fails to recognize time-out - Printable Version

+- Yealink Forums (
+-- Forum: IP Phone Series (/forumdisplay.php?fid=4)
+--- Forum: Phone specific topic (/forumdisplay.php?fid=12)
+---- Forum: T2xP Series (/forumdisplay.php?fid=21)
+---- Thread: Dial-Now fails to recognize time-out (/showthread.php?tid=1079)

Dial-Now fails to recognize time-out - braymond - 12-05-2013 10:14 AM

Hi support,

If I set the Dial-Now rules directly from the GUI, when the phone recognizes the rule, it will dial according to the "Time out for Dial-now Rule" parameter (which is 1 second).

But if I create a dial-now rule from XML and have the phone load it, then two things may happen:

1. If I have selected a line and dialed the number, it will wait for the time set by the Inter Digit Time (which is 4 seconds) before dialing

2. If I dial the number without choosing a line (so the phone picks one by default), the number is never dialed and return idle after approximately 15 seconds.

Here's the XML I am using:
<?xml version="1.0" encoding="UTF-8"?>
<Data DialNowRule="[2-9]xx[2-9]xxxxxx" LineID=""/>
<Data DialNowRule="1[2-9]xx[2-9]xxxxxx" LineID=""/>
<Data DialNowRule="3[xx]" LineID=""/>
<Data DialNowRule="*3[xx]" LineID=""/>
<Data DialNowRule="10[1-9]" LineID=""/>
<Data DialNowRule="*9[x]" LineID=""/>
<Data DialNowRule="*74[x]" LineID=""/>
<Data DialNowRule="[45689]11" LineID=""/>

I have set the url in the y000000000000.cfg as this:
dialplan_dialnow.url = tftp://

The rules do appear in the GUI so I know it was recognized.

I also tried to set LineID to a value of 1 (since I only have Account 1 configured) and that did not change anything.

I tried it from a T28P with:
Firmware version:
Hardware version:

Thanks for looking into it.

Okay, I realized what I was doing wrong. I was testing the rules that had the x within square brackets like 3[xx] ...

I removed the square brackets surrounding the x and it all works. In fact, the other rules (which I have not tested) were working.

Sorry about that but still a good learning post


RE: Dial-Now fails to recognize time-out - ivanp - 06-10-2014 09:34 AM

Also beware: Yealinks don't accept capital X, they are case-sensitive here.

RE: Dial-Now fails to recognize time-out - eddie79it - 01-31-2023 05:33 PM


I have a different issue still related to Dial-Now.

I have configured the dial-now with:
8xx - Account 1 in order to dial immediately after the match of 3 digits extensions starting with 8.

However, it dial only after the dialnow timeout.

the phone is with the latest firwmare, what i am doing wrong?