Yealink Forums
T46G - Bluetooth Headset Issue - Printable Version

+- Yealink Forums (
+-- Forum: IP Phone Series (/forumdisplay.php?fid=4)
+--- Forum: T4x Series (/forumdisplay.php?fid=31)
+--- Thread: T46G - Bluetooth Headset Issue (/showthread.php?tid=1078)

Pages: 1 2 3 4 5 6

RE: T46G - Bluetooth Headset Issue - Yealink Support - 05-15-2014 10:32 AM

Sorry. I can't make the quite anwer for you. If you want to solve the battery issue, please try below beta version .

RE: T46G - Bluetooth Headset Issue - Frank Drews - 07-09-2014 07:44 PM


I want to ask several question:
- This issue with the battery live will be fixed in V73, right?
- When is V73 to be expected?
- For V71, there was a seperate Version for 3cx, is the same to be expected von V73?
- We have the issue, that we cannot pick up and end calls with the bluetooth headset buttons? Is this a know issue? Will it be fixed with V73, too? Or can it be already be fixed somehow? We are currently on V71, 3cx

Best regards Frank

RE: T46G - Bluetooth Headset Issue - waynecollins - 03-19-2015 07:35 PM

(05-14-2014 11:22 PM)moonman407 Wrote:  I am currently using firmware v28.72.0.25 and a Plantronics Voyager Legend.

When I make or receive a call, I can hear the caller fine but all they hear is static from my side. I do not have another bluetooth to test it with but I don't have this problem with the other phones I have paired so I can only assume that it is caused by the Yealink. Is anyone else having this issue on this firmware release? It was perfectly fine before I upgraded, aside from the headset battery drain.

Did you ever find a fix to this problem? I am having the same issue with the same headset. When it was first installed it worked perfectly. But shortly afterwards and ever since, the caller on the other just gets a lot of static.

RE: T46G - Bluetooth Headset Issue - Heisenberg - 03-20-2015 05:43 PM

Just to add to this.

I have a T46G with a BT40 add on module, I was very specific in checking the official Yealink list of approved headsets and purchased the Plantronics Voyager Legend.

Initially it connects ok and works fine, but if you leave it for say an hour it then stops working correctly, for example

- Clicking the button on the headset to answer the call will not answer the call
- If the button does answer the call there is no audio at all
- Pairing quite often fails

If you then delete the pairing and readd the headset it will work again for another hour. Yealink, this headset is supposed to work!!! please help!

RE: T46G - Bluetooth Headset Issue - ngokxit - 04-01-2015 09:28 AM

Hi, seems to work on my end now. Changed firmware from to Using Plantronics Voyager Legend w/firmware 99

RE: T46G - Bluetooth Headset Issue - SixFive7 - 04-08-2015 07:23 AM

Dear Yealink,

We are also running multiple setups with a T46G + BT40 + Voyager Legend. All firmware is up to date:

Voyager Legend: 106

Still we find problems.

Most users only have a few calls an hour and experience no problems except for the need to re-pair every few days.

Some users however are part of our callcenter team. They experience heavy loads where the phone practically never stops ringing on multiple lines. In this scenario all headsets fail within the hour in one of three ways:

Sometimes the customers suddenly hear a loud static forcing them to call back.

Sometimes the headsets stop receiving or sending audio, forcing the user to disable and re-enable the headset.

But mostly the headset goes into what we call ghost mode. In this mode the headset can be enabled (green light) on the phone, but the voyager legend does not report the connection. Also, if we go into the menu, we can see the pairing has disappeared. Putting the headset into pairing mode and trying to re-pair will not succeed until the phone is power cycled. On occasion we even need to hard-reset the phone. Luckily we have a provisioning server.

Plantronics is not taking blame and is refusing to RMA their headsets. In their defense, the headsets work flawlessly on other phones and bluetooth is supposed to be generic. Also we have used them on other phones for years without incident.

The problem seems related to the bluetooth stack of the T46G. Our experience has been that on all the v72 versions the BT40 was not recognized half of the time. When it was, many attempts were required to even get a device paired. Many different beta versions in the v72 series we tried resulted in better support for recognition of the BT40 adapter, but were riddled with other bugs and performance problems. Now that the v73 version is released we were hoping our problems would disappear as one ought to think enough development time had passed. However, except for a more stable recognition of the BT40 adapter, none of our problems with the Voyager Legend have been resolved. As a result we are on the brink of going for another solution and leave the T46G phones for a lengthy RMA procedure.
Yealink, when can we expect the problems around the BT40 adapter to be resolved? Or, if never, the compatibility matrix to be updated?

Your sincerely,
A somewhat frustrated customer

RE: T46G - Bluetooth Headset Issue - Charly - 06-22-2015 05:26 PM

Dear Yealink,

We use T46G + BT40 + Jabra evolve 65.

Still we have the same 3 problems (see last post from SixFive7). All 3 - 5 days we must re-pair

We are frustrated too.

Best regards

RE: T46G - Bluetooth Headset Issue - TheInternship - 06-23-2015 10:26 PM

I'm having the same things happen to our T48Gs on the newest available firmware

RE: T46G - Bluetooth Headset Issue - Jethro - 07-06-2015 07:09 PM

We have a bunch of T46Gs and we're having problems with the bluetooth on them, we've tried lots of different firmwares, but there doesn't seem to be any difference. We're using Jabra Motions which are included in the yealink compatibility list, the bluetooth just seems to disconnect (ocassionally mid call). When we want to reconnect them sometimes we just have to go into the menu then and press connect on the headset but the majority of the time we have to remove the paired device, remove the USB bluetooth adpater and plug it back in then re-pair the devices. Why would this happen? Has anybody else had any similar issues?

RE: T46G - Bluetooth Headset Issue - Yealink_Michael - 07-07-2015 05:45 AM

hi Jethro

it is suggest to use the newest firmware and remember to do a factory reset !

firmware download link