Yealink Forums

Full Version: t46g tagged vlan not working
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello,

We have just purchased our first T46G in additional to our existing fleet of T28P phones.

We have a separate VLAN configured (VLID = 2) for phones which is working successfully for all of our T28P's - they are tagged onto VLAN 2 and use DHCP to get their IPs.

I've tried the same settings in the T46G and it will not tag onto that VLAN no matter what I try. I've tried disabling DHCP VLAN in case that was interfering.

The values I have are:
VLAN WAN Port Active: Enabled
VID 2
Priority 0

Is this a known issue?
How do I resolve it?? I'm already running the latest T46G firmware from the website (28.71.0.170)

Thanks,
Adam
Hi all,

We will release a fixed version for you in these days.
If it has been released, i will update for you.
Hi adamw,

Sorry. Our latest version has fixed this issue now.
Please refer to our website.
http://www.yealink.com/SupportDownloadfi...7&flag=142
We have tried all of the version from your website with the exact same issue.

We took a brand new T46g out of the box (never been on our network) and it behaves the same way). If you plug it in on a flat network (no voice vlan) unconfigured.. DHCP (no options) it will do one of two things.. one.. it will complain that it is unable to find network... or two (if it's on a managed switch) it will attach to the wrong Vlan.

We have a couple of locations where the networks are flat (no voice vlan possible (it's a shared infrastructure)). The T38 and T22 phones work fine. The T46g does not. If we put it on a network where the Voice VLAN is defined in the switch and we have the DHCP option set, it works fine. Otherwise we are having the same general VLAN issues. We are 100% cisco here.

I even setup a switch to be ALL access ports, and ALL set for one specific vlan. the Yeahlink T46g phones are attaching to a different VLAN entirely. I have DHCP enabled, and I have VLAN's disabled. I disabled LLDP with the same results. Our phone system is 3CX, but even with a new phone never configured, we have the same issues. Again, there are isolated ONLY to the T46g.

(01-08-2014 05:18 PM)Yealink Support Wrote: [ -> ]Hi adamw,

Sorry. Our latest version has fixed this issue now.
Please refer to our website.
http://www.yealink.com/SupportDownloadfi...7&flag=142
Can you send your issue to support.usa@yealink.com ?
Reference URL's