Yealink Forums

Full Version: No ringing tone when dialling out
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

A client of mine has an asterisk pabx and were exclusively using Bria soft phones on their laptops. They bought a W52P and 2 additional handsets and managed to set everything up without any problems except for one issue.

When you dial out you cannot hear anything in the earpiece until someone answers. There is no ringing tone at all. It is a bit weird not having a ringing tone. Anyone have any idea what I need to do to get a ringing tone when calling someone?

I have only worked with Snom and Siemens phones IP phones in the past and I have never had a problem like this before.
Hi gambit,
Sorry for the issue.
1.Is there no ringing tone when one handset calls the other handset
or it just happens when dial out?
2.The issue hapeens all the time or accidently?
3.What firmware are you using?
4.Could you provide PCAP trace(or wireshark trace), syslog(level 6) and config.bin file to us, so we can analyze?
Before you export the syslog, please set log level as 6, and reboot the phone, then click Start,and reproduce the issue, then click Stop,and export the trace, syslog, config,bin to us.
(About where to export these files, please refer to attached screenshot.)
These three files are very important for us,we will try to reproduce the issue and analyze, hope you can kindly understand.


I fixed this by setting my trunk dial options to include "r". This will force Asterisk to generate the ringing tone instead of relying on the provider/distant end to do it. There may be a setting in the Yealink as well, but if it is affecting the Yealink phone, it is likely something else will be affected as well.
Thanks for the replies. I managed to sort the problem out. The problem was only when I dialled outside numbers and not when I called internal extensions (Internal extensions had a ringing tone but outside number not). I'm not sure what caused the problem but I did the following and now it is all working correctly.

1. Upgrade base station firmware to latest (
2. Upgrade all handsets to latest firmware (

At this point there was still no ringing tone when dialling out so I did the following:

3. reset base station to factory settings
4. reset all the handsets
5. reconfigured all the sip accounts and handsets again

Finally there was now a ringing tone when calling outside numbers. Hope this helps other people.
Reference URL's