Yealink Forums

Full Version: T46G TIME Calculation Problem
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I first noticed this because the call history was showing calls as "YESTERDAY" even though they were just received.

The problem affects both manual and automatic time setting but differently.

To see the issue go to Settings->Time & Date
then Enable "Manual Time".

You will be unable to set the time to 23 hours. It will change to 0

If you set it for 22 and save it the display will show 23. Set it to 21 it will show 22.

Internally this error corrupts the calculation from the time server and DST and because of that calls in the "History" log of the phone will show as "YESTERDAY".

There really is no work around unless you want to set the wrong time.
Hi Brian,
What's the firmware are you using?
Here i am use the firmware 28.71.0.85, and it works well.
ftp://yealinkftp:yealinkftp@ftp.yealink....1.0.85.rom
Could you check again?
Thanks.
This is a nasty little bug that changes depending what you do in the UI screen. It is also dependent on whether the phone is configured or not.

I am using the same firmware as you.

If I try and set the values to the same exact values that are included in your picture and then hit Confirm two things happen. The first is that the day changes from 25 to 26 and the Hour changes to 0.

Please look at the attachment.

I just tried the same thing with another T46G running the same firmware and it INITIALLY it worked properly.

BUT If you change the DHCP Time setting on the time screen or change the Date Format from YYYY-MM-DD to WWW-MM-DD and then try to store a 23 in the hour box lots of strange things start to happen

So I did a factory reset on the phone in question and then re-tested. The time setting then works correctly BUT If I Import the previously Exported configuration the problem returns.

So it would seem there is a corruption issue that is preserved during an Export - Import.

I did another factory reset but DID NOT reload my configuration. In this case the settings work properly and the UI allows me to set 23 as the hour no matter what the other settings happen to be.

I will send you the config.bin that I am using so you can load it and test what is happening.

Something is being corrupted by my configuration. The only unusual thing in my configuration is that I have a VPN file set loaded. It is NOT enabled but it is loaded.

CONFIG.BIN FILE HAS BEEN SENT TO YOUR SUPPORT EMAIL ALSO INCLUDED IS A VIDEO OF THE ISSUE
Hi Brain,
Thanks for your config.bin and video, support.usa guy already submit this to R&D, any update they will let you know.
We're seeing the same problem on a brand new yealink T42G - the time on the phone shows correctly but all outgoing and incoming calls show YDay in the History (even though they were made today)?
Reference URL's