Yealink Forums

Full Version: T20P - After configuring Forward, the phone doesn't receive calls!
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

I don't know why, but this phone (v.9.70) has problems with registration, there are many times when it says is registered but simple doesn't receives calls, you need to reboot him!

I tried the Forward feature and didn't worked because the phone is unable to receive calls, even after disabling the Forward feature it continued unable to receive any call, I have to restart the phone, is the only solution to a low resilient registration!

Compared with any soft-phone, like Jitsi, Blink, or Ekiga, that always receive calls, and most important, are effectively aware of the registration, it makes you wonder if isn't better to buy a computer just for receive calls! Confused

Hi Rui,
1. Now you are using firmware
2. Can this phone dial out the call?
3. Did you try to reset to factory default and check again?

After checking the router NAT and PAT, and try to register my account from different devices at the same time, I concluded that the account that always missed the receiving calls, was due to the fact that the SIP provider in question only allows one device registration at time! Contrary to OnSIP, VoIP SAPO has this restriction...

The phone works well, and it maintains the register if I don't register with other device to the same account.

Thanks for your replies.


PS: My phone version:
Firmware Version   
Hardware Version 
OK thanks Rui.
Reference URL's