Yealink Forums

Full Version: VP530 Audio delays
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I have a VP530 and have a problem with audio delays on all calls. Basically, there is mild echo heard and after speaking, it can take about half a second for the other party to hear me.

I have tried a number of different Codecs and the problem remains. If I replace the VP530 with my old Aastra handset or use a sip softphone, there are no perceivable delays.

With the delays, it becomes difficult to hold a conversation because I and the other party can sometimes end up talking over each other.

I use the same login details and settings with the softphone or Aastra handset.

Any ideas?
Hello Mdspencer,
Do you use our latest firmware 23.70.0.40?
http://www.yealink.com/Upload/gujian/VP5...rmware.zip
And you can try to reset to factory default.
Do you have other Yealink phones? Do other Yealink phone also have this problem?
Thanks.
I used 23.70.248.177 which was mentioned on the firmware page as it was a higher version number. This problem occurred with the previous firmware that I was using. I shall try the firmware that you mention to see if that makes a difference.

I have no other Yealink phones as I was trying this one out to see how it performed. All other phones are either Aastra (480i) or softphones.

Ok. I have factory reset the phone and installed the suggested firmware. Still the same. I am using the PCMA codec, which I presume is G711, a-law encoding.

Using the Asterisk echo test, if I count from one two five, I literally finish saying "one" before it echoes back the "one", same with two, three, four and five. If I use my soft phones or Aastra phone, there is virtually no delay, maybe 50ms or so - it almost echoes as I speak. I am using the G711 a-law codec with the Aastra phone and the soft phones.
Hi Mdspencer,
1.Now you are using Asterisk PBX with VP530?
2.Both when you make video call and voice call, the delay problem is there?
3.Could you provide PCAP trace, syslog(level 6) and config.bin file to us, so we can analyze?
Before you export the syslog, please set log level as 6, and reboot the phone, then click Start,and reproduce the issue, then click Stop,and export the trace, syslog, config,bin to us.
(About where to export these files, please refer to attached screenshot.)
These three files are very important for us, hope you can kindly understand.
Thanks.
1. I am using the phone with the latest version of FreePBX and asterisk 1.8.20.0
2. Voice call only. I do not use the phone for video yet.
3. I will do this next week.

Regards,

Martyn Spencer

(06-04-2013 04:06 PM)Yealink Support Wrote: [ -> ]Hi Mdspencer,
1.Now you are using Asterisk PBX with VP530?
2.Both when you make video call and voice call, the delay problem is there?
3.Could you provide PCAP trace, syslog(level 6) and config.bin file to us, so we can analyze?
Before you export the syslog, please set log level as 6, and reboot the phone, then click Start,and reproduce the issue, then click Stop,and export the trace, syslog, config,bin to us.
(About where to export these files, please refer to attached screenshot.)
These three files are very important for us, hope you can kindly understand.
Thanks.
Reference URL's