Yealink Forums

Full Version: W52P No DTMF sound at IVR
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
We ordered our first W52P for evaluation and were really impressed by its quality. As we were testing it we noticed that when we dial a number we hear the DTMF tones from the keypad. However, when we are prompted by the IVR to enter an extension number and we press any of the keys on the keypad we don't hear any DTMF tones. It is as if we didn't push any of the buttons. Interestingly enough, the digits were passed onto the IVR silently because the IVR responded correctly and connected us to the desired extension or destination.

We have set the DTMF tones to United States and the DTMF Type to RFC2833. This is our general set up with all Yealink phones and they all work perfectly well with Elastix server running FreePBX We changed it on W52P to INBAND and then to SIP INFO but it didn't help. We loaded firmware and then into the base and back to the latest firmware but that didn't help either. We tried to upload the latest handset firmware by first connecting the USB port to a Windows 7 computer but got an error that there were no drivers available.

We used auto-provisioning as well as manually checking through the web interface, comparing to T28 and T22 configurations but had no luck.

I'll appreciate your advice.

It probably depend on how your PBX handles DTMF.
Did you try to go in the web interface admin of the phone, under account / advanced /

Your have DTMF TYPE and PAYLOAD.

Try to play with those settings
Thank you Simon for you prompt response.

We tested all options with other models of Yealink phones but only the RFC2833 and the default payload of 101 works in all cases for all models, including other brands.

We set the payload to the lowest and to the highest but it didn't help.

Did you check the codec ? (G711 vs G729) for example ?
Did you try to run wireshark traces on your network ?
If I had a reason to check the codecs I'd do. Can you please elaborate why you suggest that?
Hi Barnabas,
1. This issue happened every time?
2. Could you check what's your handset version? You can check it through:
Status-System Status-More-Handset-Software
3. Could you provide PCAP trace, syslog(level 6) and config.bin file to us, so we can analyze?
Before you export the syslog, please set log level as 6, and reboot the phone, then click Start,and reproduce the issue, then click Stop,and export the trace, syslog, config,bin to us.
(About where to export these files, please refer to attached screenshot.)
These three files are very important for us, hope you can kindly understand.
Thank you for your instructions.

1) It happens always
2) SW:, HW:

I have downloaded handset firmware but don't know how to upload it to the handset. USB-DECT drivers are missing in Windows 7.

Please see attached requested logs. I renamed config.bin to config-bin.txt in order to attached it.

Thank you,
Hi Barnabas,
Thanks for your reply.
Let me submit this issue to our R&D to analyze, any update will let you know soon.
Hi Barnabas,
When you use RFC2833, because the DTMF tone will only ring in the base, but not the handset, so you can't hear the DTMF tone.
But generally if you use INBAND, you can hear the DTMF tone, we tested this at our side and works, so do your server do not support INBAND type? So you can't hear the DTMF tone?
Hi Adminstrator,

Thank you for your recommendation. Our servers set the DTMF to RFC2833 by default. After changing it manually both on the the server and on the base it worked OK.

This of course requires that we set parameters manually for W52 each time. Is there a plan for a new firmware such that we can set it to work with RFC2833?

Thank you again
Pages: 1 2
Reference URL's