Yealink Forums

Full Version: Action url variable $cfg_all not working on Yealink T57W
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

In a documentation file called "Yealink SIP-T2 Series T4 Series T5 Series CP920 IP Phones Administrator Guide V85.1.pdf" I found that it is possible to export phone configuration to remote server via action url variable called $cfg_all. Documentation says that all configuration will be passed into this variable.

Instead of configuration phone just ignore this variable. Example:
1. Set action url to "Setup Completed" or "Autop Finish" with parameters https://<host>/?cfg=$cfg_all&local=$cfg_local&model=$model&mac=$mac
2. reboot the phone
3. Result on server in logs /?cfg=$cfg_all&local=$cfg_local&model=SIP-T57W&mac=<phone mac>

I tried many times and some variables (like $model, $ip, $firmware) are working but $cfg_all is not.

Please help! My task is to collect configuration from all our phones and manually download is not an option. Maybe there is some other way?
(03-18-2021 10:44 PM)Ivan86 Wrote: [ -> ]https://<host>/?cfg=$cfg_all&local=$cfg_local&model=$model&mac=$mac

Solved. The problem was in variable name in URL. Need to be ?Cfg= instead of ?cfg=.
Strange solution and no mention in documentation that GET parameter name matters too.
Reference URL's