Yealink Forums

Full Version: Are there config parameters for the Directory Settings?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I've got a number of Yealink SIP-phones (T23G, T27G, T40P models) which are configred by the Autoprovisioning from my tftp server.

I made a LDAP configuration file (ldap.cfg) (all ldap.* parameters grouped there). This file is uploaded into phones when booting (by include:config <> statement in <MAC>.boot file). All work good.

But all this phones have disabled a LDAP directory search in the Directory/Settings page ('Directory' and 'Source Search List in Dialing' Enabled Group) by default. I can't found out any configuration parameters to enable 'LDAP' for the 'Directory/Settings/Enabled' settings by autoprovisioning process.

Can somebody help me with this?
(08-19-2020 11:23 AM)xbow Wrote: [ -> ]I've got a number of Yealink SIP-phones (T23G, T27G, T40P models) which are configred by the Autoprovisioning from my tftp server.

I made a LDAP configuration file (ldap.cfg) (all ldap.* parameters grouped there). This file is uploaded into phones when booting (by include:config <> statement in <MAC>.boot file). All work good.

But all this phones have disabled a LDAP directory search in the Directory/Settings page ('Directory' and 'Source Search List in Dialing' Enabled Group) by default. I can't found out any configuration parameters to enable 'LDAP' for the 'Directory/Settings/Enabled' settings by autoprovisioning process.

Can somebody help me with this?

Hi,

You need to enable the LDAP function first.
ldap.enable = 1
or
Directory > LDAP > LDAP enable

Now you will find the desired groups in Directory > Settings

Hope this will help.
(08-19-2020 12:23 PM)complex1 Wrote: [ -> ]Hi,

You need to enable the LDAP function first.
ldap.enable = 1
or
Directory > LDAP > LDAP enable

Now you will find the desired groups in Directory > Settings

Hope this will help.

Thanks. I know about this par. My LDAP search is working well and i added the LDAP to both Enabled groups, BUT by the web interface ONLY. I need to make it through an autoprovisioning process for a lot of phones -- i can't to add LDAP in the *enabled* groups via the web-inteface for every phone. And i can't found any configuration parameters for this job.
(08-19-2020 01:12 PM)xbow Wrote: [ -> ]Thanks. I know about this par. My LDAP search is working well and i added the LDAP to both Enabled groups, BUT by the web interface ONLY. I need to make it through an autoprovisioning process for a lot of phones -- i can't to add LDAP in the *enabled* groups via the web-inteface for every phone. And i can't found any configuration parameters for this job.

Hi,

For this you need to load 2 xml files by provisioning.
static.directory_setting.url = favorite_setting.xml
super_search.url = super_search.xml


These 2 files can be found in zip file "Yealink_SIP_Phones_AutoProvisioning_Template_V8x.x.zip"
After download search in the xml files for " <item id_name="ldap" display_name="LDAP" priority="x" enable="0" " and change enable="0" into enable="1"

Hope this will help.
(08-19-2020 02:39 PM)complex1 Wrote: [ -> ]Hi,

For this you need to load 2 xml files by provisioning.
static.directory_setting.url = favorite_setting.xml
super_search.url = super_search.xml


These 2 files can be found in zip file "Yealink_SIP_Phones_AutoProvisioning_Template_V8x.x.zip"
After download search in the xml files for " <item id_name="ldap" display_name="LDAP" priority="x" enable="0" " and change enable="0" into enable="1"

Hope this will help.

O-o! This is what I missed! Thank you VERY much!
Reference URL's