Yealink Forums

Full Version: Solved Openvpn.tar creating the right size file
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi
I know this is not new and found lots of references in the forum but no solution.

We have a system that already has phones on vpn and working fine. So we built new openvpn.tar files based on that model.

When we upload via the web page is loads says "success" refreshes the screen and gone. Provisioned the VPN to be enabled but still can not upload the file. Found nothing in the logs to even show the attempts.

How do we get the config to load or log a failure?

TIA Sad:
May have found something
If I use the openvpn.tar file from a working phone it loads. Build a new file base on exactly the same data except for the key and crt files and updated auth-data, the openvpn.tar file is 20.5kB but the original working was only 11.8kB. The source files are the same size so that would imply the OS is causing the issue. Have had the same result on Centos7 and Linux Mint machines.
So the phone is rejecting the openvpn.tar file as it is too big.
Now the question of how to build a smaller tar file?
If I create a new tar file from the unchanged set of files the size is 20.5kB and unusable. Could it be a reflection of the cluster size of a newer OS? If so how can we overcome it to satisfy the phone?
Perhaps future firmware may need to accommodate varying size of the tar file.
Solved!!!
Can not make the openvpn file from command line but if you do
open Archive manager
Create new openvpn.tar file - no contents
add the keys folder and vpn.cnf file
The result is a 11.8kB file that works. The file made from the command line came out larger on 3 different machines!!!
Good to read that you have been able to solve your issue.
Reference URL's