Yealink Forums

Full Version: CP900 is bricked after upgrading VC210 FW to 118.15.0.23
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I purchased 2 VC210 Collaboration Bars which include the CP900 USB/bluetooth speaker. I figured it would be a good idea to upgrade the firmware.

After upgrading the firmware on the VC210 to 118.15.0.23 (from .20), the CP900 is not functioning. It only has the red "hang up" icon lit, but otherwise not responsive. This occurred on BOTH of my VC210s. I suspect that the CP900 firmware needs to be upgraded. It was functional when I was on the VC210 .20 FW release.

Tried to factory reset the CP900 by holding call answer/hangup for 6 seconds--No luck

Tried the Yealink USB Connect software (latest version) and the CP900 does not show up at all.

Can someone offer some guidance on what I can do to get this working?
Hi,

After upgrading the firmware on the VC210 did you factory reset the VC210?
No? Please factory reset the VC210, re-provisioning it and try again.

Hope this will help.
I have two devices which are presenting these symptoms.
Both have a red hangup icon only and are unresponsive to reboots.

Both were left connected to the VC210 devices, so I can only naturally assume they started a firmware update.

Would really like to know how to resolve this
So, I manually reflashed the CP900 by removing the cover, disconnecting the battery which allowed me to then connect it to my PC and update it.

Once I updated it to 100.420.0.20 it came back online and I went back to the room to connect it to the USB of the VC210.

Low and behold it then bricked again.

Thinking to myself - arrrgh i need to take it apart again, I did try to just connect it to my PC and it allowed me to upgrade the firmware again..

I rebooted the VC210, and verified it was on version 118.15.0.32

Connected it again, watched the screen it stated "audio upgrade in progress" then. bricked again.
I also encountered this problem after upgrading the firmware on our brand new VC210. Not a very good first impression with firmware bricking half of your setup...

When I was about to contact support, I did find this article on the CP900 Recovery Mode: http://support.yealink.com//faq/faqInfo?id=833

Basically, hold the power and volume down keys to power it off, then press them again to boot into recovery mode. You can then upload the latest firmware back onto it.

Plugging it back into the VC210 will cause it to go back to recovery mode

So for now I grabbed a spare USB power adapter that I had laying around and am using that to charge the CP900. It seems to be working fine over bluetooth audio.
The amount of CP900's getting bricked after a collaboration bar update delivered by MS Teams Admin portal is going through the roof.

We have about 15 devices in meeting rooms, I've lost count how many times we have had to power cycle them and restore them via a laptop and yealink firmware tool.

Then we just wait to have another room update pooch them.

Also, the buttons only work when they are USB connected into the VC210.
Also, just a final vent about the VC210, cannot use the TV speakers!

I should probably go eat some food. not very happy with this purchase.
(02-01-2021 02:14 PM)andrew.briggs@crrda.org.au Wrote: [ -> ]The amount of CP900's getting bricked after a collaboration bar update delivered by MS Teams Admin portal is going through the roof.

We have about 15 devices in meeting rooms, I've lost count how many times we have had to power cycle them and restore them via a laptop and yealink firmware tool.

Then we just wait to have another room update pooch them.

Also, the buttons only work when they are USB connected into the VC210.
Also, just a final vent about the VC210, cannot use the TV speakers!

I should probably go eat some food. not very happy with this purchase.

Hi Andrew,

Once the VC210 has upgraded and the CP900 reconnects, it will enter auto upgrade progress (with the pickup button on red).
You just need to wait for 1-2mins to let it complete the auto upgrade.
https://support.yealink.com/documentFron...mentId=320

CP900(CP700)-100.420.0.39.rom
VC210-118.15.0.42.rom

If the CP900 does not recover please try factory defaulting and then manually upgrade the firmware.
Connect the CP900 to a PC, then run the USB Connect Software, hold the power button for 10s, then hold the power and volume minus button for 6s, then you can upgrade the firmware manually via the USB connect software.

BR
Link
Reference URL's