Yealink Forums

Full Version: CP960 Teams Shared Mode
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I've setup a Room resource account and assigned it a Meeting Room license for Teams following Jeff Schertz's guidance. When I log this account into our CP960 running I'm not prompted to choose if the login is Shared or Personal like described in pages 11 through 13 of the "Yealink_CP960-Teams_edition_User_guide_V15.45.pdf" linked below.

Does anyone know how to get the account switched over to Shared mode? As it stands the user is defaulted to personal mode which allows any user to delete bookings from the room resource calendar.
Same Issue as the OP.
Can't find a shared mode for this phone on the latest build.
(10-15-2019 11:19 PM) Wrote: [ -> ]Same Issue as the OP.
Can't find a shared mode for this phone on the latest build.

Are you able to downgrade your device? What I've noticed is our T55a's out of the box had the shared/personal option but the latest build for them don't so I'm hoping the same is true for the CP960 which I foolishly upgraded before using.

Unfortunately, I can't downgrade either the T55a's or CP960's I have as it complains I need to install a SIP license. I've tried applying both the appropriate Teams version of the firmware and the non-Teams version with the same error. Factory reset just clears user settings and keeps the same firmware.
I was able to downgrade my CP960 to and unfortunately this and every other firmware version up to the current show the same behavior of skipping the profile selection step and defaulting to personal.

You can generate a license for the downgrade here:
Yealink support has mentioned that only Common Area Phone is supported in the most recent firmware and that an account with a CAP license should automatically enable the shared mode. I've told them this isn't the case in practice but am still waiting for a reply over a week later.

It seems we can only hope a new firmware update solves this issue.
Still no response from Yealink support on my ticket.
No response from the support team on my ticket for this issue.
We've figured this out now, Microsoft and Yealink neglected to include that you must set the login behavior for Common Area and Meeting Room phones through a policy, Get,Set,New,Remove,Grant-CSTeamsIPPhonePolicy and it doesn't simply work after applying a license.

Once we granted a policy that included CommonAreaPhoneSignIn to our account and waited around 3 hours we were able to log into the CP960 and have it correctly login as a Common Area Phone.

The same is true for Meeting Room.
>No response from the support team on my ticket for this issue.

As much as I like Yealink kit, their support is pretty awful. I've raised three legitimate tickets over the last year and never got a response :-(

It's not like the CP960 are a ***** bit of kit from China. They're nudging towards £500 in the UK.
Reference URL's