Yealink Forums

Full Version: 3CX / Yealink passthrough VLAN issue (when phone is rebooted)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

This is an example how our network works.

VLAN50 = vlan for phones
VLAN80 = vlan for computers connected to phones

Switch port is set to
50 untagged, 80 tagged.

In 3cx for the Phone Provisioning, VLAN Configuration, Enable VLAN for PC PORT 80

If I connect a phone up, it gets the correct settings, works on VLAN50 etc. Connecting a PC to the PC port after the phone has booted, will result in the PC being on VLAN80. However if we then reboot the phone, the PC port will at first be given VLAN50, we are then required to disconnect and reconnect the network cable to rest the network connection of the PC to get the correct VLAN.

Is there a way of telling the Yealink phones to hold off sending traffic to the PC port until the phone has fully booted? It seems to act as a dumb switch until it has booted and provisioned fully.

This is in a 150+ phone/pc set up, so making any other changes to the switches / configuration would be a real pain.

Thanks in advance.

3cx version
Professional Perpetual 15.5.15502.6License

Yealink T42S fw
Yealink T19P_E2 fw
Hi Sir, how are you today?

This is Evan from Yealink Support Team, nice to know you here!

(1) Have you disabled LLDP and CDP features? Can you disable them, then test again? =0 =0

(2) If above doesn't help, please reproduce this issue, and offer us the diagnosis files, then we can check more. Below is the FAQ about how to capture diagnosis files.
a. Connects a phone up;
b. Starts to capture diagnosis files, then connect the PC to PC port;
c. After reproducing this issue, export the diagnosis files.

Best Regards,
Evan You

Can this be done in 3CX?

I don't fancy logging into every phone to do this.
Hi Sir,

Yes, you can do it via 3CX template file, auto provisioning. Using below auto provision parameters. =0 =0

Best Regards,
Evan You
Reference URL's