Yealink Forums

Full Version: Autoprovisionong T4xS v83 error
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

does anyone know if there was any change in auto provisioning for firmware version 66.83.x.xx for T4xS phones, because it stops working after upgrading.
I searched documentation and forum, but couldn't find anything.

I have phones T42S, T46S and T48S.

In my y0000000000xx.cfg files I tell them to upgrade firmware:
firmware.url = t

It all worked fine, but after upgrading to it stopped working for all phones.
On phone I get message: "Unable to complete. Will try again now!"
On TFTP server I get message: "TIMEOUT waiting for Ack block #1"

I tried to upgrade to 83.0.10, 83.0.20, 83.0.35 and 84.0.10. It all works from v82, but after upgrade to any of these firmwares, it stops working.

I can still do manual firmware upgrade and downgrade via web browser, but it doesn't work via TFTP autoprovisioning any more.

Does anyone else have this problem?
Any help would be appreciated.

Regards, Gasper
Hi Gasper,

Well I can confirm that upgrading from on a T41S via TFTP works. For testing I added the following line:

firmware.url = tftp://10.168.x.x:69/T41S(T42S)-

And can confirm the phone rolled back the firmware to 82.0.40 as requested without issue. I did not try with v83 since you said you were still having the issue in 84.0.10 and Yealink always wants tests done with the latest available firmware.

Maybe something strange on your TFTP server?
Thank you for the hint Jolouis, it is working now.

I'm using TFTPD64 TFTP server and after your message I tried to install same TFTP on a different machine. It also didn't work, so I installed different TFTP server. It worked, so I browsed through parameters. I changed value of the parameter "Negociate" from 1 to 0 and now it seems to be OK, but I'm not sure why. I think it has something to do with the packet size...

BR, Gašper
Reference URL's