Yealink Forums

Full Version: T46S autoprovision settings reverting to defaults
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello, I have a network of ten T46S and two T48S phones, configured using autoprovisioning. For the most part this seems to work, the phones pick up the settings correctly. However after some time (15-60 minutes) the phones will revert several of the autoprovisioned settings back to defaults. The settings that revert are:

Time&Date -> Time Format: reverts to 24 hours after being set to 12 hours.
Power Saving -> Idle TimeOut: Office Hour Idle TimeOut is set to 960 minutes, but reverts to 15 minutes.

There are other settings this happens on but these are the most important to my users. Autoprovisioning is configured to repeat every 60 minutes but that does not help - once the settings are reverted they do not update again. Rebooting or autoprovisioning triggered manually via the web interface does not help. Making changes to the config files (even superficial changes) and then trying an autoprovision will usually make it work, but then once again after some time it reverts.

I have also noticed that the phones do not detect updated firmware files on tftp, example my phones are on firmware 66.9.0.23, I have changed the tftp firmware file to 66.9.0.25 (filename remains the same), but no phones have updated. What is wrong here?

My autoprovision config files:

y000000000066.cfg
Code:
#!version:1.0.0.1

static.network.cdp.enable = 0
features.remember_password.enable = 1
features.intercom.enable = 1
features.intercom.outgoing = 1
features.intercom.allow = 1
static.firmware.url = tftp://192.168.100.243/latest-firmware-t46s.rom
features.sign_in_via_btoe.enable = 0
features.pin_authentication.enable = 0
features.web_sign_in_enable = 1
features.user_sign_in.enable = 0
phone_setting.phone_lock.enable = 0

features.power_saving.enable=1
features.power_saving.office_hour.monday=7,18
features.power_saving.office_hour.tuesday=7,18
features.power_saving.office_hour.wednesday=7,18
features.power_saving.office_hour.thursday=7,18
features.power_saving.office_hour.friday=7,18
features.power_saving.office_hour.saturday=7,18
features.power_saving.office_hour.sunday=7,18
features.power_saving.user_input_ext.idle_timeout=30
features.power_saving.off_hour.idle_timeout=10
features.power_saving.office_hour.idle_timeout=960
features.power_saving.intelligent_mode=1

static.auto_provision.repeat.enable = 1
static.auto_provision.repeat.minutes = 60

mac.cfg
Code:
#!version:1.0.0.1

local_time.time_zone = -8
local_time.time_zone_name = Canada(Vancouver,Whitehorse)
local_time.ntp_server1 = 192.168.100.243
local_time.ntp_server2 = 192.168.100.243
local_time.interval = 3600
local_time.summer_time = 2
local_time.dst_time_type = 0
local_time.manual_time_enable = 0
local_time.manual_ntp_srv_prior = 0
local_time.time_format = 0
local_time.date_format = 3
Dear Customer,

Thanks for contacting us. These issues cause by the phone syncing with the SFB online server configuration settings. You can change the Microsoft policy settings to solve these issue.

For the time format issue you can refer the link:http://support.yealink.com/faq/faqInfo?id=705

For the power saving issue, you can set the Microsoft policy "Set-CsIPPhonePolicy -EnablePowerSaveMode $False" to disable this feature.
Microsoft policy set the Office Hour Idle TimeOut to 15min by default.

For the firmware update issue

1.You can set the policy parameter "Set-CsIPPhonePolicy -EnableDeviceUpdate $False" first;
2.Then the the phone will not download firmware from the Skype for Business server. The phone will choose to download firmware via central provisioning (if configured).
3.Isuggest that change your firmware name to 66.9.0.25 format.

Please let us know if it works for you.

Thanks!
(02-02-2018 05:21 AM)Aaron_Yealink Wrote: [ -> ]Dear Customer,

Thanks for contacting us. These issues cause by the phone syncing with the SFB online server configuration settings. You can change the Microsoft policy settings to solve these issue.

For the time format issue you can refer the link:http://support.yealink.com/faq/faqInfo?id=705

For the power saving issue, you can set the Microsoft policy "Set-CsIPPhonePolicy -EnablePowerSaveMode $False" to disable this feature.
Microsoft policy set the Office Hour Idle TimeOut to 15min by default.

For the firmware update issue

1.You can set the policy parameter "Set-CsIPPhonePolicy -EnableDeviceUpdate $False" first;
2.Then the the phone will not download firmware from the Skype for Business server. The phone will choose to download firmware via central provisioning (if configured).
3.Isuggest that change your firmware name to 66.9.0.25 format.

Please let us know if it works for you.

Thanks!

Thanks I can confirm SfB settings worked. I did not realize they overrode my autoprovision settings. I am waiting to test firmware updates and will let you know.
Reference URL's