Yealink Forums

Full Version: Wrong name displayed when dialing extension
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello,

I have a stumper and am not able to find the information anywhere, please help! For simplicity, lets use "A" as the old name, "B" as the new name and 123 as the extension tied to the name.

In short:
The company directory was updated with extension 123 changing from name "A" to name "B". When dialing extension 123 from a local phone, name "A" and "B" show up. BUT when the call starts to dial, the name shows up correct as user "B".

Findings:
The issue is with the call history. If I delete old calls made to extension 123, then the correct name will show up (B) when dialing the extension.

Question:
Is there an auto-provision that could overwrite call history of extension 123 with the correct name? OR an auto-provision that will look to the company directory first, if no information is present, then look to the call history...

Why:
It would be simple to just delete the old user out of call history but when you multiply this by every phone in the company (large company), this can be a daunting tasks, especially when new users are changed around on a monthly basis.

Additional Information:
Only name "A" shows up when dialing the extension, even after an auto-provision. Have to manually update the Directory on a phone, reboot, then the correct name shows up on the screen in addition to the old name.

HELP!
Hello,

I want to confirm something with you firstly.
1. What's phone model and firmware in your side?

2. What's your company directory? Remote phone book? LDAP directory? Local phone book?

3. How many phones in your company?

4. When dialing extension 123 from a local phone, name "A" and "B" show up. BUT when the call starts to dial, the name shows up correct as user "B".
--- As my understanding, in dial interface, you enter 123, then phone match name 'A' and 'B', you choose one of them to dial out, the phone show up 'B', right? If I have any misunderstanding, please correct me.
(09-30-2017 01:32 AM)Karl Wrote: [ -> ]Hello,

I want to confirm something with you firstly.
1. What's phone model and firmware in your side?

2. What's your company directory? Remote phone book? LDAP directory? Local phone book?

3. How many phones in your company?

4. When dialing extension 123 from a local phone, name "A" and "B" show up. BUT when the call starts to dial, the name shows up correct as user "B".
--- As my understanding, in dial interface, you enter 123, then phone match name 'A' and 'B', you choose one of them to dial out, the phone show up 'B', right? If I have any misunderstanding, please correct me.

1. Its a T29G on firmware 46.80.0.25
2. I'm not sure what information you need here but they have two Directory's, one has 35 contacts and the other has 66.
3. Over 100 and most of them are in the field.
4. Exactly correct!

Thank you for your reply.
Somebody? Anybody?
(10-09-2017 12:52 PM)DavidA Wrote: [ -> ]Somebody? Anybody?
Sorry, we have a long National holiday about one week.
About your question, I test locally with latest firmware version.
And it don't happen, I just suggest upgrade to the latest firmware then do a test.
You can download the latest firmware from the link below.
Link: http://download.support.yealink.com/down...2.0.20.rom

My test step:
1. Add contact A as locally directory.
2. Number A call in, picked up. The history stored as contact A.
3. Change contact A to B with same number.
4. Same number call in, picked up, the history stored as contact B.
5. The previous history change name from A to B automatic.
6. When dial the number, the phone only show contact B
Reference URL's