Yealink Forums

Full Version: speaker on auto answer
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I enabled auto answer function on line1, but when call is being auto answered, sound goes to handset and nobody hears it, so
How can i enable auto answer with speaker, instead of headphone?
Can you check for me what is the model and firmware version of the phone?
How many phones have the problem?

If the model is DECT(W52 or W56), then you can use the parameter via auto provision below to disabled the handset auto answer:
custom.handset.auto_answer.enable=0
If the phone model is not DECT, then please provide the level 6 syslog, config.bin and pace trace for me to double check, i wil use your configuration to do test in my local side.

Thank you.
(07-04-2017 06:17 AM)Lucia Wrote: [ -> ]Can you check for me what is the model and firmware version of the phone?
How many phones have the problem?

If the model is DECT(W52 or W56), then you can use the parameter via auto provision below to disabled the handset auto answer:
custom.handset.auto_answer.enable=0
If the phone model is not DECT, then please provide the level 6 syslog, config.bin and pace trace for me to double check, i wil use your configuration to do test in my local side.

Thank you.

Model of my phone is T21P E2, with firmware version 52.81.0.110.
I have only one yeastar phone, so this problem is only on one phone.
Syslog [attachment=4416] and [attachment=4415] .
Thank you for your reply.
Have already submit the files to our R&D to check. Any update, will let you know.
(07-04-2017 09:04 AM)Lucia Wrote: [ -> ]Thank you for your reply.
Have already submit the files to our R&D to check. Any update, will let you know.

Are you still there?
I'm waiting for 1.5 days for your answer.
I don't know what to do.
Yes, i am still here.
For this problem, our R&D are doing test and analyzing now. You know, it need time to solve problem.

As i can see in the log:

[SIP] <IPC_ntfp>:msg=0x00040105, wparam=0, lparam=32770, size=848, id=Undefied on dspg
<134>Jul 4 07:02:19 Log [1111]: VOIC<6+info > HandFree Status = [0]
<134>Jul 4 07:02:19 Log [1111]: VOIC<6+info > HandSet Status = [1]

It looks like the problem occured when the phone send message to the UI part. The UI invoke the HandSet instead of the HandFree.
And our R&D are doing test and try to locate the problem, but still need more time to fix it.

Please be patient, any update for this issue, i will let you know.

Best Regards
Lucia
(07-06-2017 07:29 AM)Lucia Wrote: [ -> ]Yes, i am still here.
For this problem, our R&D are doing test and analyzing now. You know, it need time to solve problem.

As i can see in the log:

[SIP] <IPC_ntfp>:msg=0x00040105, wparam=0, lparam=32770, size=848, id=Undefied on dspg
<134>Jul 4 07:02:19 Log [1111]: VOIC<6+info > HandFree Status = [0]
<134>Jul 4 07:02:19 Log [1111]: VOIC<6+info > HandSet Status = [1]

It looks like the problem occured when the phone send message to the UI part. The UI invoke the HandSet instead of the HandFree.
And our R&D are doing test and try to locate the problem, but still need more time to fix it.

Please be patient, any update for this issue, i will let you know.

Best Regards
Lucia

I just wanted to make sure, that i'm not forgotten, sorry for misunderstanding.
Best regards
Sergey_9_
Our R&D have done a lot of test, when the phone receive and auto answer the incoming call, the phone judge the handset is off hook, so the auto answer the call via handset, it is by design.

So please check if the handset is on hook. Two reason may cause this problem, please help to check:
1. you do not connect the handset or the handset is on hook.
2. the on hook key is demaged.

If when you press the on hook key, it still auto answer from the Speaker, then please help to do the test below:
press the on hook key for many times
press the Speaker key for many times

At the same time, provide the video of the whole test, the level 6 syslog, config.bin and pace trace for us to do further analyze.
Please export the log to the server side.
Refer to the FAQ to capture the three files:support.yealink.com/faq/faqInfo?id=313

Thank you.
(07-07-2017 08:01 AM)Lucia Wrote: [ -> ]Our R&D have done a lot of test, when the phone receive and auto answer the incoming call, the phone judge the handset is off hook, so the auto answer the call via handset, it is by design.

So please check if the handset is on hook. Two reason may cause this problem, please help to check:
1. you do not connect the handset or the handset is on hook.
2. the on hook key is demaged.

If when you press the on hook key, it still auto answer from the Speaker, then please help to do the test below:
press the on hook key for many times
press the Speaker key for many times

At the same time, provide the video of the whole test, the level 6 syslog, config.bin and pace trace for us to do further analyze.
Please export the log to the server side.
Refer to the FAQ to capture the three files:support.yealink.com/faq/faqInfo?id=313

Thank you.

Hi Lucia!
After reading your answer i decided to check all you mentioned above and i discovered that my phone have non standard handset (i bought this phone on ebay) and size of handset is way too big to press on hook key.
Now i wonder how did i missed that...

I tried to press on hook button manually and call once more, all worked just great, it auto answered with speaker instead of handset.

Thanks for your help and have a nice day!
Best regards
Sergey_9_
Reference URL's