Yealink Forums

Full Version: VP 2009 unable to boot, safe boot or upgrade?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi All,

New member here Smile

Been browsing the forums for the past few days on clues to getting an old VP-2009 working. It's the 128mb version and refuses to boot up, if left powered on the system initialisation screen will hang and will eventually fade to a white screen.

History on this phone is unknown unfortunately as with the current firmware version. I discovered it laying around our stock room and appears to have never been used other than the odd fiddling by colleagues that have been and gone so there's no chance of asking them.

So far I've tried the suggested recovery options of holding the speaker phone key or second function key whilst it boots but these do nothing. After a bit of meddling I noticed if I hold the "OK" button I get a "Boot Menu" in which I found no documentation on how to use but muddled my way around it regardless. If anyone has some documentation on this Boot Menu I'd appreciate a link to it Smile

I've attached a picture of the boot menu if anyone recognises it. Option 5 (Command Boot) returns "???Do Command Boot Failure!!!" and Option 6 (Console) asks for a password which isn't admin, password or passwd.

I've attempted doing the V4X upgrade using the tools and instructions found in the following blog ( ) but once the phone accepts the files and starts to load I get "Upgrade failed" Sad

Firmware I've tried to push onto the phone are , , , and from what I still have downloaded.

Any suggestions would be much appreciated. From what the other posts imply the phone is probably beyond recovering but I figured it's worth a shot because it's a shame to let this one go to waste.

Kind regards
In submitting this post my original account got banned for spam Sad
Made a new account so I can still reply to responses.

Had no luck still flashing the phone back to life as of yet.
Getting somewhere I think, I've managed to push firmware to it and get a bugged out initialising screen (See Yealink VP-2009 1.jpg) where a pattern of grey lines show across the screen.

Oddly enough since doing so the holding the "OK" button no longer takes me to that weird debug screen and instead allows me to use the "Speaker" key or "Function 2" to access recovery settings (See Yealink VP-2009 2.jpg)

So far my other firmware versions are currently not bringing the phone past the bugged initialising screen.

Anyone got a collection of firmware versions I can throw at this thing?
Looks like only VP530 firmware can be loaded "successfully" on this thing at the moment which is also probably why I'm getting no luck trying to boot the thing when it does successfully take firmware Sad

VP2009 versions tried

VP530 versions tried

Any other versions floating about on the web or on a hard drive somewhere I can try?

If not I might try finding the UART on the board and flashing it as at this point it's just a fancy looking night light ;p
HI Sir,

Can you check for me what is your current firmware version is?
And which version you want to upgrade to?
Hi Lucia,

Thanks for the response, I'm currently sitting on firmware for the VP530

Kind regards
Hi Lucia,

Forgot to reply to the latter of your response.

I don't really mind what version of firmware is on it, at the moment it won't boot with the ones I've tried listed in earlier posts.

If you've got a few others I can try that'd be great or an alternative bootloader as I feel the one I'm using is designed for the VP530 hence why the VP2009 firmware fails to even load onto the system.

Many thanks
HI Peter,

Have send you an email, please check. Thank you.
Hi TTC Peter

Did you manage to solve this? I have exactly the same issue.

Reference URL's