Yealink Forums

Full Version: T42G stuck on Welcome Initializing... please wait
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi, I have a three phones that are all stuck on the Welcome Initializing Screen. Is there a way to bypass this or do a factory reset? I don't like the fact that I have three phones that are completely useless to me. Please let me know if anyone can help.

Thank you.
I don't believe there is much that can be done if the phone won't actually boot up fully. (From what I recall factory reset can only be triggered from idle, not during the boot process.. I could be wrong).

Do you at least see the phones grabbing IP addresses from your DHCP server, or do they not even get that far?

Have you tried new local power adapters or a different POE switch, just to make sure it's not a power problem?

If possible I would say your best approach would be to try and warranty replace them (if they are still under warranty); not sure there is going to be much else you will be able to do...
HI Jeremyiia,

This is Lucia from Yealink Technical Support team.

For your problem, please contact your distributor to do recovery mode update for you. They will be happy to help you.

Regards,
Lucia
(03-31-2017 02:19 AM)Lucia_Yealink Wrote: [ -> ]HI Jeremyiia,

This is Lucia from Yealink Technical Support team.

For your problem, please contact your distributor to do recovery mode update for you. They will be happy to help you.

Regards,
Lucia


Hi Lucia,

Is there any other way to get past this? We purchased the phones on our own and do not have a distributor.

Thanks

Manny Mejias
Reference URL's